Older versions of add-ons which have been marked as compatible on AMO cannot be installed

VERIFIED DUPLICATE of bug 610041

Status

--
major
VERIFIED DUPLICATE of bug 610041
8 years ago
3 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

Details

(Whiteboard: [4rc][addons-testday], URL)

Mozilla/5.0 (Windows NT 5.1; rv:2.0b12pre) Gecko/20110220 Firefox/4.0b12pre

If you are trying to install an older version of an addon which has been marked as compatible on AMO but has a lower maxVersion for the application, it cannot be installed.

Steps:
1. Create a fresh profile
2. Opent the all versions page of the ACR add-on
3. Try to install version 0.7

The installation fails with the message that the add-on is not compatible with Firefox 4b12pre.

Messages from the error console:

LOG addons.xpi: Download started for https://addons.mozilla.org/firefox/downloads/file/101926/add-on_compatibility_reporter-0.7-fx+tb+sm.xpi?src=version-history to file C:\DOCUME~1\mozilla\LOCALS~1\Temp\tmp-xza.xpi

LOG addons.xpi: Download of https://addons.mozilla.org/firefox/downloads/file/101926/add-on_compatibility_reporter-0.7-fx+tb+sm.xpi?src=version-history completed.

LOG addons.updates: Requesting https://versioncheck.addons.mozilla.org/update/VersionCheck.php?reqVersion=2&id=compatibility@addons.mozilla.org&version=0.7&maxAppVersion=4.0b8pre&status=userEnabled,incompatible&appID={ec8030f7-c20a-464f-9b0e-13a3a9e97384}&appVersion=4.0b12pre&appOS=WINNT&appABI=x86-msvc&locale=en-US&currentAppVersion=4.0b12pre&updateType=49

LOG addons.updates: Found an update entry for compatibility@addons.mozilla.org version 0.8

LOG addons.xpi: Cancelling download of https://addons.mozilla.org/firefox/downloads/file/101926/add-on_compatibility_reporter-0.7-fx+tb+sm.xpi?src=version-history

It looks like that if a new compatible version is available, we cancel the download of the old version, and don't install it.
blocking1.9.2: ? → ---
blocking2.0: --- → ?
OS: Windows XP → All
Hardware: x86 → All
FYI, version 0.7 was uploaded with a maxVersion of 4.0b8pre. It was later marked as 4.0.* compatible in the AMO developer hub.
A nuisance, and I'm worried it might point to a bigger problem, but inability to download older versions of addons is not, in itself, a blocker.
blocking2.0: ? → -
Not a regression at all, this is a long-standing issue with how AMO implements the update service and only gives us information about the latest version of an add-on.
Component: Add-ons Manager → API
Keywords: regression, regressionwindow-wanted
Product: Toolkit → addons.mozilla.org
QA Contact: add-ons.manager → api
Whiteboard: DUPEME
Version: Trunk → unspecified
(In reply to comment #3)
> Not a regression at all, this is a long-standing issue with how AMO implements
> the update service and only gives us information about the latest version of an
> add-on.

Dave, the case covered by this bug is working perfectly fine in Firefox 3.6, but fails in Firefox 4. So I do not think that this is a bug on AMO side.
Keywords: regression, regressionwindow-wanted
(In reply to comment #4)
> (In reply to comment #3)
> > Not a regression at all, this is a long-standing issue with how AMO implements
> > the update service and only gives us information about the latest version of an
> > add-on.
> 
> Dave, the case covered by this bug is working perfectly fine in Firefox 3.6,
> but fails in Firefox 4. So I do not think that this is a bug on AMO side.

Which add-on are you testing that with? ACR works just fine on 3.6 because it includes compatibility with 3.6 in its install.rdf and doesn't need the update check.
(In reply to comment #5)
> Which add-on are you testing that with? ACR works just fine on 3.6 because it
> includes compatibility with 3.6 in its install.rdf and doesn't need the update
> check.

Try to install Mozmill 1.5.1 from the page below. It is marked as compatible with Firefox 4 but cannot be installed:

https://addons.mozilla.org/en-US/firefox/addon/mozmill/versions/

It's even not possible to install those older addons from disk. As consequence it will completely block QA from running any update tests for add-ons in the add-ons manager.
Whiteboard: DUPEME → [4rc][addons-testday][DUPEME]
(In reply to comment #6)
> It's even not possible to install those older addons from disk. As consequence
> it will completely block QA from running any update tests for add-ons in the
> add-ons manager.

We will probably upload our own test extensions which have been marked as compatible with 4.0.*, so we can test extension updates.

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 610041
Status: RESOLVED → VERIFIED
Keywords: regression, regressionwindow-wanted
Whiteboard: [4rc][addons-testday][DUPEME] → [4rc][addons-testday]
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.