Last Comment Bug 636149 - Home Page -> Use Current Pages; Does not respect Tab groups
: Home Page -> Use Current Pages; Does not respect Tab groups
Status: VERIFIED FIXED
[4b12]
:
Product: Firefox Graveyard
Classification: Graveyard
Component: Panorama (show other bugs)
: Trunk
: All All
: P3 normal
: Firefox 6
Assigned To: Tim Taubert [:ttaubert]
:
Mentors:
Depends on:
Blocks: 653099
  Show dependency treegraph
 
Reported: 2011-02-23 06:25 PST by bugzilla
Modified: 2016-04-12 14:00 PDT (History)
7 users (show)
bzbarsky: in‑testsuite?
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
screenshot showing unsolicited spam tab from spam ISP when Use Current Pages selected (410.79 KB, image/png)
2011-04-29 08:39 PDT, Derek Williams
no flags Details
patch v1 (1.19 KB, patch)
2011-04-30 03:32 PDT, Tim Taubert [:ttaubert]
gavin.sharp: review+
Details | Diff | Review
patch for checkin (1.14 KB, patch)
2011-05-02 17:01 PDT, Tim Taubert [:ttaubert]
no flags Details | Diff | Review

Description bugzilla 2011-02-23 06:25:17 PST
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110222 Firefox/4.0b12pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110222 Firefox/4.0b12pre

Only the current pages in the current tab group should be set as home, instead every page from all groups are, and they are all brought into the active group when clicking on the home button.

Perhaps there should be a url scheme to allow tab groups to be bookmarks or set as home pages etc.

Reproducible: Always

Steps to Reproduce:
1. separate some pages into groups
2. options > home page > use current pages
3. all pages are added
Comment 1 juan becerra [:juanb] 2011-02-23 08:46:47 PST
I can see the problem as described here. If the user's intention is to use the current pages as viewed in the current state in panorama, then this doesn't work as expected, because all the tabs come up in the same group. Nomination for clarification.
Comment 2 Kevin Hanes 2011-02-23 10:00:14 PST
Technically we're doing exactly what the button says even though some of your pages are not in your current view. I agree that we could do better here in conjunction with Panorama.

Unless it's blocking, I think this is a post-Fx4 issue.
Comment 3 Mike Beltzner [:beltzner, not reading bugmail] 2011-02-23 11:34:30 PST
Yeah, not a blocker.
Comment 4 Derek Williams 2011-04-29 08:37:58 PDT
I have an issue that may be related.  When I choose Use Current Pages, Firefox adds a spam ISP site and a blank Tab, neither of which is a current page when I choose Use Current Pages.

Below is what was saved:
http://mail.derekwilliams.net/zimbra/#7|http://community.vsl.co.at/forums/|http://www.facebook.com/|http://commonsenseatheism.com/?p=15167|http://by148w.bay148.mail.live.com/default.aspx?wa=wsignin1.0|https://mail.google.com/mail/?hl=en&shva=1#inbox|http://extranet.inpho.com.au/livr/dw/dw_status.php?action=line_status|http://timeanddate.com/worldclock/|http://translate.google.com/#auto|en||http://dictionary.reference.com/

I am attaching an image of what opens.  I contacted their Abuse team, to no avail.
Comment 5 Derek Williams 2011-04-29 08:39:29 PDT
Created attachment 529113 [details]
screenshot showing unsolicited spam tab from spam ISP when Use Current Pages selected

screenshot showing unsolicited spam tab from spam ISP when Use Current Pages selected
Comment 6 Tim Taubert [:ttaubert] 2011-04-30 03:32:52 PDT
Created attachment 529276 [details] [diff] [review]
patch v1
Comment 7 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-05-02 16:37:04 PDT
Comment on attachment 529276 [details] [diff] [review]
patch v1

While you're at it, you could update the XXX comment to be a "FIXME: Bug 244192".

You could also replace all of this code with:

var tabs = win.gBrowser.visibleTabs;
function getTabURI(t) t.linkedBrowser.currentURI.spec;
var newVal = tabs.map(getTabURI).join("|");
Comment 8 Tim Taubert [:ttaubert] 2011-05-02 17:01:28 PDT
Created attachment 529611 [details] [diff] [review]
patch for checkin

(In reply to comment #7)
> While you're at it, you could update the XXX comment to be a "FIXME: Bug
> 244192".

Done.

> You could also replace all of this code with:
> 
> var tabs = win.gBrowser.visibleTabs;
> function getTabURI(t) t.linkedBrowser.currentURI.spec;
> var newVal = tabs.map(getTabURI).join("|");

That's much better :) Done.
Comment 9 Boris Zbarsky [:bz] (Out June 25-July 6) 2011-05-03 16:37:05 PDT
http://hg.mozilla.org/projects/cedar/rev/ec5747dbbfed
Comment 10 Boris Zbarsky [:bz] (Out June 25-July 6) 2011-05-04 13:52:35 PDT
http://hg.mozilla.org/mozilla-central/rev/ec5747dbbfed
Comment 11 George Carstoiu 2011-05-20 04:25:00 PDT
 Mozilla/5.0 (X11; Linux i686; rv:6.0a1) Gecko/20110519 Firefox/6.0a1

Verified issue using steps from Comment 0 on Ubuntu 10.10, WinXP, Mac OS X 10.6, Win 7. Bug is no longer present.

Note You need to log in before you can comment on or make changes to this bug.