When someone opens a SUMO KB article in edit mode, notify this to other users

RESOLVED WORKSFORME

Status

--
enhancement
RESOLVED WORKSFORME
8 years ago
5 years ago

People

(Reporter: underpass_bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; it; rv:1.9.2.14) Gecko/20110218 Firefox/3.6.14
Build Identifier: 

A good feature we lost is the locking of articles when someone opens them in edit mode. In TikiWiki, when this happened, everyone else got a message saying 

"This article is currently being modified by <username>"

Often we happen to change the same article in the same time and the restore of this feature would be appreciated.

Thanks.

Reproducible: Always
(Reporter)

Updated

8 years ago
Summary: Lock an article when someone opens it in edit mode → When someone opens it in edit mode, notify this to other users
An even better solution would b
Status: UNCONFIRMED → NEW
Ever confirmed: true
Just disregard my last comment please. I only wanted to change the status of the bug.
It's not necessary to lock as two edits at the same time will simply result in two different revisions in the history--i.e. nothing will ever be "overwritten." (It is up to a user to manually merge the two revisions, since this is a wiki, not git.)

How often do simultaneous edits to the same article actually happen?
(Reporter)

Comment 4

8 years ago
The aim is only to avoid consuming localizers' time.
In recent times I often started to work on a translation after receiving a notification, and found that my fellows localizers did the same :)
I understand, but we have a pretty long list of development tasks as it is, so knowing how big of a problem this is will help us triage and prioritize.
James, the merging thing is not too useful for localizers, usually they will update an article and do the same work twice. 

I guess a complete solution for this problem would take too much time, how about a quick and dirty one? If a second person starts to edit the same article within an hour, show a message to the secon editor that "($user) has started to edit the article ($minutes) ago". When I think about it, it's probably not so quick either, hmm.
You'd need to track all started edits within an hour, and check against that list everytime someone click on "edit/translate"
(In reply to comment #7)
> You'd need to track all started edits within an hour, and check against that
> list everytime someone click on "edit/translate"

Yes, it's not simple or quick at all. That's why I'm trying to get a sense of the impact.
(In reply to comment #3)
> How often do simultaneous edits to the same article actually happen?

Hi James,
Last time yesterday. I was editing simultaneously with Simone (I couldn't know) and after submitting my edit I discovered that the edit was already done. So I had to reject my edit. Wasted time for nothing :)

Usually we coordinate ourselves with a message in a special section on Mozilla Italia forum, but expecially if an edit is very simple and fast, after receiving a notification, we do it immediately without telling each other.

I believe that, before starting his edit, it's important for a localizer to be warned if another localizer is editing simultaneously.
I understand perfectly well that it's not simple at all ;)
it just happened to me too, so +1 for that bug, even if it is not a big priority...

Updated

7 years ago
Duplicate of this bug: 700163

Updated

7 years ago
Summary: When someone opens it in edit mode, notify this to other users → When someone opens a SUMO KB article in edit mode, notify this to other users

Comment 12

5 years ago
We fixed this in another bug. Closing as works for me.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.