Create mobile design for personas detail page

RESOLVED FIXED in Q2 2011

Status

P2
normal
RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: clouserw, Assigned: grlicky)

Tracking

unspecified
Q2 2011

Details

(URL)

(Reporter)

Description

8 years ago
We need a mobile design for this page in the spirit/layout of the other AMO designs:

  https://addons.allizom.org/en-US/firefox/addon/grey__lines/
(Reporter)

Updated

8 years ago
Duplicate of this bug: 633548
(Reporter)

Comment 2

8 years ago
ETA: Early April
Target Milestone: Q1 2011 → Q2 2011
(Reporter)

Updated

8 years ago
Target Milestone: Q2 2011 → 6.0.7
(Assignee)

Comment 3

8 years ago
Here is a first stab at some hi-fi mockups for the details page:

http://people.mozilla.com/~jgrlicky/drop/AMO/mobile_mockups/personas/details.html

Again, I welcome your feedback ^_^
Target Milestone: 6.0.7 → Q2 2011
(Reporter)

Comment 4

8 years ago
Cool, comments:

The header stands out again.  Maybe to get your link back to Mobile add-ons we could use breadcrumbs.  All the rest of MAMO's pages have "Mobile Add-ons Home" at the top, we coule make that "Mobile Add-ons >> All Personas"

You've got links to the artist and "some rights reserved" on this page.  Does the artist have a listing page?  Is Some Rights Reserved a popup, or a separate page?  Does it have a mobile page?

"Personas by this artist" should be above the "See all $category Personas" blob in my opinion.  (And that's consistent with the current site).
Overall, nothing jumps out at me. In the "Trying it on" details page, in the final state (installed it), the "Trying it on" button is kinda taking up space. Maybe collapse it? It's not a huge deal.

The breadcrumbs take up a little space, but it might not be a problem. I don't know if we have the enough width for Wil's idea ("Mobile Add-ons >> All Personas") or not. Also not a huge deal imo.
(Assignee)

Comment 6

8 years ago
Wil - as you mentioned on IRC, the header (and the one on the home page) matches the one on MAMO, so that should be fine.

Yep, the artist should have their own listing page, also linked from "see all personas by this artist." If I'm not overlooking anything, it should be the exact same as the category page, except with "Personas by ______" as the page title, instead of the category name.

Good call on making the artist/category blob order consistent with the AMO. Now corrected in the mockups.

The license page linked from here should be the creativecommons.org page for the specific license, like http://creativecommons.org/licenses/by-nc-sa/3.0/. They don't have a mobile-friendly license page, but I don't think it's not worth linking to the license because of that.

Luckily, after the user's installed the persona, they're pretty much done with this page, so the "Trying it on" button taking up space is definitely not a big deal.

Barring any further concerns, I'd say this page is ready to get implemented!
(Reporter)

Comment 7

8 years ago
Thanks.  Implementation is bug 654310
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.