Scrollable Panorama Space+Send To Group Feature

RESOLVED INVALID

Status

Firefox Graveyard
Panorama
--
enhancement
RESOLVED INVALID
7 years ago
2 years ago

People

(Reporter: Threshold, Unassigned)

Tracking

Trunk
x86_64
Windows 7

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b13pre) Gecko/20110227 Firefox/4.0b13pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b13pre) Gecko/20110227 Firefox/4.0b13pre

The available space for Panorama should be scrollable like a webpage (if feasible) thus allowing to have an unlimited number of groups.

As it is now, if you have just 2 groups with say 30 tabs and want to see the tabs inside each group (say to rearrange between them or to create a third group) you have to enlarge groups so much that you have already taken up all of the available space.

Even if you keep groups at the bare minimum size you can't have more than that many groups.


Another thing I would add is a "send to" feature to send one or more tabs (selectable say via check-boxes) from one group to another group or a new group.


Reproducible: Always

Updated

7 years ago
Version: unspecified → Trunk

Comment 1

7 years ago
Mozilla/5.0 (Windows NT 6.1; rv:2.0b12) Gecko/20100101 Firefox/4.0b12

*Note: This would be an enhancement.
(Reporter)

Comment 2

7 years ago
Hello Andrei I hope I have filled everything properly.

I just come up with a further suggestion.

Since large groups of tabs would take too much space anyway even with a scrollable space (which I have no idea if it is technically feasible) we could have set of labels on the right side of the Panorama space ( a bit like pinned tabs but larger)each indicating a group of tabs.

The labels would have the name of the group and different colours like in a real office archive.

Tabs inside each group could be moved\copied to other groups by drag and dropping like files in Windows.

The labels of each group could even be visible in the main Fireox window thus allowing switching between groups without having to go through the panorama space.

Comment 3

7 years ago
We're aggressively avoiding having scrollbars in the Panorama UI. Currently we have a couple of ideas to figure out how to "expand" your usable space.

bug 628990 sounds like it might implement nearly all of what you want to accomplish. We are also considering making Panorama zoomable.

Additionally, you may utilize our existing "send to" feature, if you like. Go into a group, right click on the tabs in the tab bar and "send to". Please note that this feature requires your groups to be named.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

7 years ago
(In reply to comment #3)
> We're aggressively avoiding having scrollbars in the Panorama UI. Currently we
> have a couple of ideas to figure out how to "expand" your usable space.
> 
> bug 628990 sounds like it might implement nearly all of what you want to
> accomplish. We are also considering making Panorama zoomable.
> 
> Additionally, you may utilize our existing "send to" feature, if you like. Go
> into a group, right click on the tabs in the tab bar and "send to". Please note
> that this feature requires your groups to be named.

Hello Kevin and thanks for the feedback.

My second suggestion (the labels) wouldn't require scrollbars but I am sure you guys will come up with something good.


I don't entirely agree on bug 628990 since my main issue at present is the available space and even if we could rearrange tabs while stacked there is still that much space for stacked groups (I probably just have too many tabs but with TabGroupManager+BarTab I manage them quite well).

I will experiment with your suggestion.

Thank you
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.