Last Comment Bug 637253 - decomtamination: remove nsIPlugin and nsIPluginInstance
: decomtamination: remove nsIPlugin and nsIPluginInstance
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: All All
-- normal with 1 vote (vote)
: ---
Assigned To: Josh Aas
:
: Benjamin Smedberg [:bsmedberg]
Mentors:
Depends on: 657868
Blocks: deCOM
  Show dependency treegraph
 
Reported: 2011-02-28 00:07 PST by Josh Aas
Modified: 2011-07-11 04:07 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix v1.0 (101.13 KB, patch)
2011-02-28 00:08 PST, Josh Aas
no flags Details | Diff | Splinter Review
fix v1.1 (101.24 KB, patch)
2011-03-14 05:59 PDT, Josh Aas
no flags Details | Diff | Splinter Review
fix v1.2 (105.88 KB, patch)
2011-03-14 08:16 PDT, Josh Aas
no flags Details | Diff | Splinter Review
remove nsIPlugin, v1.0 (12.07 KB, patch)
2011-04-21 21:53 PDT, Josh Aas
no flags Details | Diff | Splinter Review
remove nsIPlugin, v1.1 (11.77 KB, patch)
2011-04-29 08:45 PDT, Josh Aas
no flags Details | Diff | Splinter Review
remove nsIPlugin, v1.2 (12.45 KB, patch)
2011-05-10 09:18 PDT, Josh Aas
benjamin: review+
Details | Diff | Splinter Review
remove nsIPlugin, v1.3 (12.43 KB, patch)
2011-05-11 08:16 PDT, Josh Aas
no flags Details | Diff | Splinter Review
remove nsIPluginInstance, v1.0 (96.41 KB, patch)
2011-05-12 14:24 PDT, Josh Aas
no flags Details | Diff | Splinter Review
remove nsIPluginInstance, v1.1 (100.78 KB, patch)
2011-05-12 16:20 PDT, Josh Aas
no flags Details | Diff | Splinter Review
remove nsIPluginInstance, v1.2 (107.92 KB, patch)
2011-05-12 20:00 PDT, Josh Aas
benjamin: review+
Details | Diff | Splinter Review
remove nsIPluginInstance, v1.3 (109.34 KB, patch)
2011-05-17 15:25 PDT, Josh Aas
no flags Details | Diff | Splinter Review
expose nsNPAPIPluginInstance::GetJSContext (1.85 KB, patch)
2011-07-10 07:41 PDT, lekma
no flags Details | Diff | Splinter Review

Description User image Josh Aas 2011-02-28 00:07:51 PST
We don't need nsIPlugin or nsIPluginInstance. We should get rid of them.
Comment 1 User image Josh Aas 2011-02-28 00:08:57 PST
Created attachment 515571 [details] [diff] [review]
fix v1.0

Compiles and works for 32-bit Mac OS X. Probably doesn't even compile on other platforms yet.
Comment 2 User image Josh Aas 2011-02-28 00:58:43 PST
This would break non-libxul builds. We should stop making the plugin code its own library and just build it with dom/plugins. I'll file a new bug and make this depend on that.
Comment 3 User image Ted Mielczarek [:ted.mielczarek] 2011-02-28 05:00:25 PST
We are going to intentionally remove the --disable-libxul build configuration post-4.0, FWIW. Fewer configurations to support + more opportunities for deCOM like this.
Comment 4 User image Josh Aas 2011-03-14 05:59:34 PDT
Created attachment 519122 [details] [diff] [review]
fix v1.1

Update to current trunk.
Comment 5 User image Josh Aas 2011-03-14 08:16:48 PDT
Created attachment 519146 [details] [diff] [review]
fix v1.2

Linux build fixes.
Comment 6 User image Josh Aas 2011-04-21 21:53:22 PDT
Created attachment 527721 [details] [diff] [review]
remove nsIPlugin, v1.0
Comment 7 User image Josh Aas 2011-04-29 08:45:36 PDT
Created attachment 529114 [details] [diff] [review]
remove nsIPlugin, v1.1
Comment 8 User image Josh Aas 2011-05-10 09:18:25 PDT
Created attachment 531348 [details] [diff] [review]
remove nsIPlugin, v1.2

A better way to deal with nsPluginHost::GetPlugin.
Comment 9 User image :Ms2ger (⌚ UTC+1/+2) 2011-05-10 09:23:38 PDT
Why still inherit from nsISupports?
Comment 10 User image Josh Aas 2011-05-10 10:03:31 PDT
(In reply to comment #9)
> Why still inherit from nsISupports?

I'm planning to stop doing that but I want to limit the size/depth of each patch. I'll get that in another set of patches soon.
Comment 11 User image Josh Aas 2011-05-11 08:16:50 PDT
Created attachment 531637 [details] [diff] [review]
remove nsIPlugin, v1.3

Update to current trunk.
Comment 12 User image Josh Aas 2011-05-11 13:25:12 PDT
pushed nsIPlugin interface removal to mozilla-central

http://hg.mozilla.org/mozilla-central/rev/6eb2b03b6fd5
Comment 13 User image Josh Aas 2011-05-12 14:24:30 PDT
Created attachment 532028 [details] [diff] [review]
remove nsIPluginInstance, v1.0
Comment 14 User image Josh Aas 2011-05-12 16:20:29 PDT
Created attachment 532067 [details] [diff] [review]
remove nsIPluginInstance, v1.1

Linux compile fixes.
Comment 15 User image Josh Aas 2011-05-12 20:00:53 PDT
Created attachment 532105 [details] [diff] [review]
remove nsIPluginInstance, v1.2

Windows build fixes.
Comment 16 User image Josh Aas 2011-05-17 15:25:01 PDT
Created attachment 533090 [details] [diff] [review]
remove nsIPluginInstance, v1.3

QT build fixes.
Comment 17 User image Josh Aas 2011-05-17 18:54:01 PDT
pushed nsIPluginInstance interface removal to mozilla-central

http://hg.mozilla.org/mozilla-central/rev/5ffdf4967dec
Comment 18 User image AndreiD[QA] 2011-07-01 06:25:32 PDT
Setting this as Verified as of #comment 17
Comment 19 User image lekma 2011-07-10 07:41:45 PDT
Created attachment 545072 [details] [diff] [review]
expose nsNPAPIPluginInstance::GetJSContext

Since nsNPAPIPluginInstance isn't an XPCOM component anymore there is no way for a plugin to get the JSContext associated with an instance. This patch try to remedy it. I'm not sure this is the right way to do it.
Comment 20 User image Josh Aas 2011-07-10 23:25:48 PDT
Thanks for your contribution, but please file a new bug for any further patches, this bug is closed out and done.
Comment 21 User image lekma 2011-07-11 04:07:27 PDT
OK. filed: https://bugzilla.mozilla.org/show_bug.cgi?id=670629
Thanks for your help.

Note You need to log in before you can comment on or make changes to this bug.