Last Comment Bug 638056 - #error "The cacheFlush support is missing on this platform." on mips, s390 and ia64
: #error "The cacheFlush support is missing on this platform." on mips, s390 an...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All Linux
: -- normal (vote)
: mozilla6
Assigned To: Mike Hommey [:glandium]
:
Mentors:
: 620368 627668 630854 659888 (view as bug list)
Depends on: 652628
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-02 03:01 PST by Mike Hommey [:glandium]
Modified: 2011-06-14 13:53 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Avoid "The cacheFlush support is missing on this platform" error on exotic platforms (545 bytes, patch)
2011-03-18 01:29 PDT, Mike Hommey [:glandium]
cdleary: review+
Details | Diff | Review

Description Mike Hommey [:glandium] 2011-03-02 03:01:03 PST
Previously, one didn't need to --disable something to successfully build on exotic architectures. This particular failure seems to be related to

ifeq (,$(filter-out powerpc sparc,$(TARGET_CPU)))
here -> http://mxr.mozilla.org/mozilla-central/source/js/src/Makefile.in#378

It looks like the logic is reversed here, and that it should use a filter instead. It also looks like this should be enclosed in a ifdef ENABLE_something.
Comment 1 Mike Hommey [:glandium] 2011-03-18 01:29:49 PDT
Created attachment 520157 [details] [diff] [review]
Avoid "The cacheFlush support is missing on this platform" error on exotic platforms

I tested this on s390, and this allows to build a working engine. I will test other architectures soon.
Comment 2 Landry Breuil (:gaston) 2011-04-15 02:39:53 PDT
(In reply to comment #1)
> Created attachment 520157 [details] [diff] [review]
> Avoid "The cacheFlush support is missing on this platform" error on exotic
> platforms
> 
> I tested this on s390, and this allows to build a working engine. I will test
> other architectures soon.

Yes please, tested working fine on OpenBSD/amd64 (which correctly enters in assembler/) and OpenBSD/sparc64 (which doesnt gets there). OpenBSD/mips64el test on the way.

Previously, i was using 
+ifneq (,$(filter-out sparc64,$(TARGET_CPU)))
 CXXFLAGS += -DUSE_SYSTEM_MALLOC=1 -DENABLE_ASSEMBLER=1 -DENABLE_JIT=1
+else
+CXXFLAGS += -DUSE_SYSTEM_MALLOC=1
+endif

using --disable-tracejit --disable-methodjit on sparc64 was not enough.

but mike's patch looks ways saner. Maybe enclose it within ENABLE_JIT test ? anyone can test on i386/amd64 with --disable-tracejit ?

Btw, forcing -DENABLE_ASSEMBLER=1 -DENABLE_JIT=1 at the end of Makefile.in regardless of the arch looks weird.

And i think https://bugzilla.mozilla.org/show_bug.cgi?id=620368 & https://bugzilla.mozilla.org/show_bug.cgi?id=630854 could be marked as dupes of this bug.
Comment 3 Mike Hommey [:glandium] 2011-04-15 02:49:09 PDT
(In reply to comment #2)
> Btw, forcing -DENABLE_ASSEMBLER=1 -DENABLE_JIT=1 at the end of Makefile.in
> regardless of the arch looks weird.

Yet, it apparently builds and works fine, provided the js engine actually works (cf. jsvalue problems on ia64 and sparc64).
Comment 4 Mike Hommey [:glandium] 2011-04-15 02:49:46 PDT
*** Bug 630854 has been marked as a duplicate of this bug. ***
Comment 5 Mike Hommey [:glandium] 2011-04-15 02:50:22 PDT
*** Bug 620368 has been marked as a duplicate of this bug. ***
Comment 6 Landry Breuil (:gaston) 2011-04-15 02:50:51 PDT
Confirmed producing a working js binary on OpenBSD/mips64el. Well, at least it runs like on sparc64, independently of the jsvalue problems we're likely to meet on mips64 too.
Comment 7 Mike Hommey [:glandium] 2011-04-15 02:53:57 PDT
(In reply to comment #2)
> using --disable-tracejit --disable-methodjit on sparc64 was not enough.
> 
> but mike's patch looks ways saner. Maybe enclose it within ENABLE_JIT test ?
> anyone can test on i386/amd64 with --disable-tracejit ?

I think --disable-something bugs should be separated.
Comment 8 Chris Leary [:cdleary] (not checking bugmail) 2011-04-21 22:14:26 PDT
Comment on attachment 520157 [details] [diff] [review]
Avoid "The cacheFlush support is missing on this platform" error on exotic platforms

Don't actually know the syntax, but the semantics look good! Feel free to r? someone who knows the syntax better if you're at all concerned about it.
Comment 9 Mike Hommey [:glandium] 2011-04-22 01:34:31 PDT
http://hg.mozilla.org/mozilla-central/rev/59771590e920
Comment 10 Boris Zbarsky [:bz] (Out June 25-July 6) 2011-05-26 09:38:26 PDT
*** Bug 659888 has been marked as a duplicate of this bug. ***
Comment 11 Anton Shterenlikht 2011-05-27 04:38:01 PDT
With the patch firefox-4.0.1 builds for me
on FreeBSD ia64 9.0 -current.

However, it dumps core on startup.
Comment 12 Wayne Mery (:wsmwk, NI for questions) 2011-06-14 13:53:36 PDT
*** Bug 627668 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.