Last Comment Bug 652628 - Fix for 638056 breaks MeeGo armv7 build
: Fix for 638056 breaks MeeGo armv7 build
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: ARM MeeGo
: -- major (vote)
: mozilla6
Assigned To: Mike Hommey [:glandium]
:
Mentors:
Depends on:
Blocks: 638056
  Show dependency treegraph
 
Reported: 2011-04-25 13:25 PDT by Lokesh Goel
Modified: 2011-04-26 23:43 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Full Error Log (367.42 KB, text/plain)
2011-04-25 13:25 PDT, Lokesh Goel
no flags Details
Mozconfig used (1.93 KB, text/plain)
2011-04-25 13:28 PDT, Lokesh Goel
no flags Details
Add armel in the opt-in for the nitro assembler (548 bytes, patch)
2011-04-25 23:36 PDT, Mike Hommey [:glandium]
no flags Details | Diff | Splinter Review
This patch seems to solve the problem (549 bytes, patch)
2011-04-26 13:52 PDT, Lokesh Goel
no flags Details | Diff | Splinter Review
Probably this is a better way. (547 bytes, patch)
2011-04-26 14:09 PDT, Lokesh Goel
no flags Details | Diff | Splinter Review
Use arm% in the opt-in for the nitro assembler (543 bytes, patch)
2011-04-26 14:11 PDT, Mike Hommey [:glandium]
cdleary: review+
Details | Diff | Splinter Review

Description Lokesh Goel 2011-04-25 13:25:47 PDT
Created attachment 528157 [details]
Full Error Log

PACKAGE VERSION:
mozilla-central 68416:59771590e920

ENVIRONMENT:
MeeGo(rpmbuild) armv7el

Looks like the patch for bug#638056 breaks the armel build for MeeGo. See the errors below:

/usr/bin/python2.6 /home/abuild/rpmbuild/BUILD/mozilla-central/js/src/config/pythonpath.py -I../config /home/abuild/rpmbuild/BUILD/mozilla-central/js/src/config/expandlibs_exec.py --uselist --  c++ -o js  -frtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=vfpv3 -mfloat-abi=softfp -D__SOFTFP__ -fno-strict-aliasing -pthread -march=armv5te -mthumb-interwork -msoft-float -pipe  -DNDEBUG -DTRIMMED -g -g -O2 -fno-tree-ter -fno-ipa-reference -fno-tree-switch-conversion  js.o jsworkers.o   -lpthread -Wl,--no-keep-memory,-rpath-link,/home/abuild/rpmbuild/BUILD/release/dist/bin/:/usr/lib:/lib   -Wl,-rpath-link,/bin -Wl,-rpath-link,/home/abuild/rpmbuild/BUILD/release/dist/lib  -L../../../dist/bin -L../../../dist/lib -L/usr/lib -lplds4 -lplc4 -lnspr4 -lpthread -ldl ../editline/libeditline.a ../libjs_static.a -ldl     
../libjs_static.a(jsapi.o): In function `~ExecutablePool':
/home/abuild/rpmbuild/BUILD/mozilla-central/js/src/assembler/jit/ExecutableAllocator.h:128: undefined reference to `JSC::ExecutablePool::systemRelease(JSC::ExecutablePool::Allocation const&)'

Also find attached the full rawlog of the build and the mozconfig used.
Comment 1 Lokesh Goel 2011-04-25 13:28:32 PDT
Created attachment 528159 [details]
Mozconfig used
Comment 2 Lokesh Goel 2011-04-25 13:29:01 PDT
Reversing 68416:59771590e920 fixes the issue.
Comment 3 Mike Hommey [:glandium] 2011-04-25 14:13:38 PDT
What is TARGET_CPU on meego ? armel ?
Comment 4 Lokesh Goel 2011-04-25 18:39:15 PDT
(In reply to comment #3)
> What is TARGET_CPU on meego ? armel ?

YES
Comment 5 Mike Hommey [:glandium] 2011-04-25 23:36:00 PDT
Created attachment 528272 [details] [diff] [review]
Add armel in the opt-in for the nitro assembler
Comment 6 Lokesh Goel 2011-04-26 13:25:32 PDT
(In reply to comment #5)
> Created attachment 528272 [details] [diff] [review]
> Add armel in the opt-in for the nitro assembler
I am sorry, but this fix doesn't solve the problem. I tried this and it doesn't fix the issue.

We build for two arm architectures in MeeGo armv7el(softfp) and armv8el(hardfp), the TARGET_CPU for MeeGo armv7el target seems to be "armv7l".
Comment 7 Lokesh Goel 2011-04-26 13:38:26 PDT
"armv7l" is the TARGET_CPU for both armv7el and armv8el. armv8el is actually armv7el + hardfp.
Comment 8 Lokesh Goel 2011-04-26 13:52:24 PDT
Created attachment 528429 [details] [diff] [review]
This patch seems to solve the problem
Comment 9 Lokesh Goel 2011-04-26 14:09:08 PDT
Created attachment 528435 [details] [diff] [review]
Probably this is a better way.
Comment 10 Mike Hommey [:glandium] 2011-04-26 14:11:46 PDT
Created attachment 528437 [details] [diff] [review]
Use arm% in the opt-in for the nitro assembler

Even better
Comment 11 Mike Hommey [:glandium] 2011-04-26 23:43:52 PDT
http://hg.mozilla.org/mozilla-central/rev/c833fb1623ca

Note You need to log in before you can comment on or make changes to this bug.