Remove "Not Now" menuitem from popup notifications

RESOLVED DUPLICATE of bug 1282768

Status

()

defect
RESOLVED DUPLICATE of bug 1282768
8 years ago
3 years ago

People

(Reporter: Margaret, Unassigned)

Tracking

(Depends on 1 bug, {uiwanted})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [doorhanger])

Attachments

(1 attachment)

Reporter

Description

8 years ago
Because we ended up implementing bug 615315, I think we should get rid of the "Not Now" menuitem in popup notifications.

If we get rid of that menuitem, we should WONTFIX bug 615441.
Reporter

Comment 1

8 years ago
Posted patch patchSplinter Review
This is basically a backout of the patch from bug 615318, but some things needed to stay in for the close button to work (bug 615315).
Assignee: nobody → margaret.leibovic
Status: NEW → ASSIGNED
Attachment #520325 - Flags: ui-review?(faaborg)
Attachment #520325 - Flags: review?(gavin.sharp)
Comment on attachment 520325 [details] [diff] [review]
patch

The redundancy built in here is kind of controversial, but the objective was to allow the user to view every available choice in a single organized list, so that they didn't have to store previously viewed choices in memory (main action, close button) as they simultaneously consider the alternate commands.  So in conjunction with the work proposed over in bug 615441, I'm in favor of keeping the "not now" command in this list.
Attachment #520325 - Flags: ui-review?(faaborg) → ui-review-
Reporter

Comment 3

8 years ago
I understand that design, and I agree that if we keep the "Not Now" menuitem, we should also have a redundant main command.

However, I've seen users click on the "Not Now" menuitem, and it's a painfully slow interaction. I feel like users are more likely to learn that they can click outside to close the notification if they don't have the "Not Now" option, but they will still have the close button in case they can't figure out that click outside to close interaction.

I understand that once they already open the dropdown menu, it is probably slower to hit the close button than to choose "Not Now", but for single-action notifications, I feel like we're wasting users' time if they click on the dropdown out of curiosity, only to see that the only additional option is "Not Now".

I'm also cc'ing Limi because we were just talking about this now, and he agrees with these points.
>I feel like we're wasting users' time if they click on the
>dropdown out of curiosity, only to see that the only additional option is "Not
>Now".

Yeah, I totally agree with that.  Regardless of bug 615441, there shouldn't be a drop down if there are no alternate commands.
Having the not-now option there can be harmful even for notifications that have multiple secondary actions - users who are just discovering this new UI could conclude (based on its presence) that it's the only way to dismiss the notification. I suppose now that we've already shipped it we kind of have that problem regardless...
Attachment #520325 - Flags: review?(gavin.sharp)
(In reply to Alex Faaborg [:faaborg] (Firefox UX) from comment #4)
> >(In reply to Margaret Leibovic [:margaret] from comment #3)
> >I feel like we're wasting users' time if they click on the
> >dropdown out of curiosity, only to see that the only additional option is "Not
> >Now".
> 
> Yeah, I totally agree with that.  Regardless of bug 615441, there shouldn't
> be a drop down if there are no alternate commands.

If I implement this (not adding "Not now" if there are no secondary actions), will it be accepted? It seems like there is agreement on this portion.
Reporter

Comment 7

7 years ago
(In reply to Matthew N. [:MattN] from comment #6)
> (In reply to Alex Faaborg [:faaborg] (Firefox UX) from comment #4)
> > >(In reply to Margaret Leibovic [:margaret] from comment #3)
> > >I feel like we're wasting users' time if they click on the
> > >dropdown out of curiosity, only to see that the only additional option is "Not
> > >Now".
> > 
> > Yeah, I totally agree with that.  Regardless of bug 615441, there shouldn't
> > be a drop down if there are no alternate commands.
> 
> If I implement this (not adding "Not now" if there are no secondary
> actions), will it be accepted? It seems like there is agreement on this
> portion.

I like this idea. I'm probably not the person who needs to okay this, though :)
Assignee: margaret.leibovic → nobody
(In reply to Matthew N. [:MattN] from comment #6)
> If I implement this (not adding "Not now" if there are no secondary
> actions), will it be accepted? It seems like there is agreement on this
> portion.

Yes please!
Bulk move to Toolkit::Notifications and Alerts

Filter on notifications-and-alerts-component.
Component: General → Notifications and Alerts
Product: Firefox → Toolkit
Version: Trunk → unspecified
Not now will be removed from permission prompts as part of bug 1188147's dependencies.
Status: ASSIGNED → NEW
Depends on: 1188147
I am removing Not Now in bug 1282768.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1282768
You need to log in before you can comment on or make changes to this bug.