Last Comment Bug 639362 - Files with MIME-type text/cache-manifest should display in-browser instead of being downloaded
: Files with MIME-type text/cache-manifest should display in-browser instead of...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: All All
: -- enhancement with 1 vote (vote)
: mozilla16
Assigned To: Matthew N. [:MattN] (PM me if requests are blocking you)
:
:
Mentors:
http://developers.whatwg.org/offline....
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-06 12:16 PST by Dan Wolff
Modified: 2012-07-14 19:58 PDT (History)
5 users (show)
MattN+bmo: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v.1 Based on patch to bug 667533 for JSON (7.63 KB, patch)
2012-07-13 20:12 PDT, Matthew N. [:MattN] (PM me if requests are blocking you)
MattN+bmo: review+
Details | Diff | Splinter Review

Description Dan Wolff 2011-03-06 12:16:08 PST
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b12) Gecko/20100101 Firefox/4.0b12
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0b12) Gecko/20100101 Firefox/4.0b12

Simply handle text/cache-manifest files the same way as text/plain.

Reproducible: Always
Comment 1 George Carstoiu 2011-03-10 02:42:32 PST
Mozilla/5.0 (X11; Linux i686; rv:2.0b13pre) Gecko/20110309 Firefox/4.0b13pre

Dan, can you please provide some clear steps to reproduce this issue. 

Also, maybe provide a testcase in order for us to use and check the bug you've reported.

Thanks!
Comment 2 Dan Wolff 2011-03-10 04:50:15 PST
I'm sorry. I honestly thought it was very self-explanatory.
This is a feature request. As such, I've also changed the platform to "all" since this is by design, and not a bug.

This MIME-type is part of the new HTML specification: http://www.whatwg.org/specs/web-apps/current-work/multipage/offline.html#writing-cache-manifests
> Manifests must be served using the text/cache-manifest MIME type.

Steps to reproduce:
* Go to http://developers.whatwg.org/offline.manifest

Actual result:
A save dialog is shown, prompting the user to download the file or open it with some local application.

Expected result:
The text of that document is shown.
Comment 3 Dan Wolff 2011-03-10 04:52:24 PST
Additionnally, both Opera and Chrome display the text of such files directly in the browser, handling them very much the same way as text/plain.
Comment 4 Maxime RETY 2012-02-01 02:40:58 PST
As a developer, I think it's indeed really convenient to display the manifest file directly in the browser (say for debugging purpose).

As of Firefox 11, the situation has not changed.

Will it be implemented eventually ?
Or should the issue be closed ?
Comment 5 Matthew N. [:MattN] (PM me if requests are blocking you) 2012-07-13 20:12:31 PDT
Created attachment 642165 [details] [diff] [review]
v.1 Based on patch to bug 667533 for JSON

Here is a patch making the same changes as were made for JSON in bug 667533 plus adding the type to nsHTMLDocument::StartDocumentLoad and actually adding the test to the Makefile.

Pushed to try: http://tbpl.mozilla.org/?tree=Try&rev=a87ecf6aad7a
Comment 6 Boris Zbarsky [:bz] (still a bit busy) 2012-07-13 20:27:08 PDT
Comment on attachment 642165 [details] [diff] [review]
v.1 Based on patch to bug 667533 for JSON

r=me
Comment 7 Matthew N. [:MattN] (PM me if requests are blocking you) 2012-07-14 12:22:11 PDT
Comment on attachment 642165 [details] [diff] [review]
v.1 Based on patch to bug 667533 for JSON

Try run: https://tbpl.mozilla.org/?tree=Try&rev=a87ecf6aad7a
Comment 8 Matthew N. [:MattN] (PM me if requests are blocking you) 2012-07-14 12:23:07 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/a138ec3bdb65
Comment 9 Ryan VanderMeulen [:RyanVM] 2012-07-14 19:58:11 PDT
https://hg.mozilla.org/mozilla-central/rev/a138ec3bdb65

Note You need to log in before you can comment on or make changes to this bug.