Last Comment Bug 639564 - Letters on SVG Wow "Text Effects" demo (in the 3rd row on the 4th page) are placed over each other
: Letters on SVG Wow "Text Effects" demo (in the 3rd row on the 4th page) are p...
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://svg-wow.org/text-effects/text-...
Depends on: 649114
Blocks: lazyfc
  Show dependency treegraph
 
Reported: 2011-03-07 11:33 PST by Laszlo Mocsar
Modified: 2012-02-07 01:42 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Laszlo Mocsar 2011-03-07 11:33:50 PST
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b12) Gecko/20100101 Firefox/4.0b12
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b12) Gecko/20100101 Firefox/4.0b12

Letters in the 3rd row on the 4th page are placed over each other in the center of the line, instead of placed side by side, as in the above lines.

Reproducible: Always

Steps to Reproduce:
1. Load the web-page
2. Wait for page #4 (bouncing letters)

Actual Results:  
Letters in the 3rd row on the 4th page are placed over each other in the center of the line.

Expected Results:  
Letters should be placed side by side, as in the above lines.

This works fine in the latest 3.x version of FireFox (3.6.15 now).
Comment 1 Daniel Holbert [:dholbert] 2011-03-07 14:15:52 PST
Confirmed broken in trunk and working in 1.9.2 branch (Firefox 3.6.14)

From a quick glance at the page source, I can't immediately tell what's going on in that slide -- the demo is dynamically generated from script, and it looks like there are a few scripts involved.

So, a reduced testcase would be pretty helpful here.

Mozilla/5.0 (X11; Linux x86_64; rv:2.0b13pre) Gecko/20110303 Firefox/4.0b13pre
Comment 2 Robert Longson 2011-03-07 14:35:04 PST
A regression range might well help too. Lazco, are you willing to help with either the reduced testcase or the regression range?
Comment 3 Laszlo Mocsar 2011-03-07 23:35:47 PST
I do not know, how to make a reduced testcase or regression range, I just noticed the bug and reported it.
Comment 4 Alice0775 White 2011-03-07 23:45:02 PST
Regression window(m-c hourly):
Works:
http://hg.mozilla.org/mozilla-central/rev/021bf8e64199
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100413 Minefield/3.7a5pre ID:20100416094911
Fails:
http://hg.mozilla.org/mozilla-central/rev/935bb616b8a6
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100413 Minefield/3.7a5pre ID:20100416121540
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=021bf8e64199&tochange=935bb616b8a6

In local build,
build from 699e6f9a3660 : fails
build from 7a19bc84e572 : fails
build from f80de1a7c604 : fails
build from aa6171e5b8e7 : works
build from e6ba6ff50841 : works
build from c7a4f2c4ba7a : works
Triggered by
f80de1a7c604	Timothy Nikkel — Bug 502937. Part 3. Implement lazy frame construction. r=bzbarsky sr=roc
Comment 5 Daniel Holbert [:dholbert] 2011-03-07 23:47:19 PST
Laszlo: Ok - thanks anyway!

Alice0775: You rock.
Comment 6 Timothy Nikkel (:tnikkel) 2011-03-22 23:45:59 PDT
Narrowing this down, it seems to be something about setting the transform attribute on an SVG element that doesn't have a frame yet.
Comment 7 Laszlo Mocsar 2011-04-05 16:50:25 PDT
The relevant part seems to me (just doing a dumb search) in: 
   http://svg-wow.org/res/3.0/scripts/tools/text-effects.js
starting at the 
   "effectsLib['bouncing-letters'] = {" 
line.
Comment 8 Laszlo Mocsar 2011-06-22 13:53:00 PDT
Still present in:
Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0
Comment 9 Daniel Holbert [:dholbert] 2011-10-28 14:08:10 PDT
(sorry, didn't mean to unassign; reassigning)
While I'm already spamming with a comment, I'll note that this is still present in trunk:
Mozilla/5.0 (X11; Linux x86_64; rv:10.0a1) Gecko/20111028 Firefox/10.0a1
Comment 10 Timothy Nikkel (:tnikkel) 2011-10-28 14:21:37 PDT
I haven't been active on this in a while, if anyone else wants to pick this up it would be okay with me. I think the bug is somewhere in the SVG code that handles updating of transforms.
Comment 11 Laszlo Mocsar 2011-11-09 06:10:16 PST
Seems, that with Firefox version 8.0, the sound has gone as well!
Can someone confirm it?
Comment 12 Timothy Nikkel (:tnikkel) 2012-02-06 15:49:27 PST
Fixed by bug 649114.

Note You need to log in before you can comment on or make changes to this bug.