Last Comment Bug 639794 - Opening a webpage from an external app should hide sidebars and panels
: Opening a webpage from an external app should hide sidebars and panels
Status: VERIFIED FIXED
[regression]
:
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Trunk
: ARM Android
: P3 normal (vote)
: Firefox 8
Assigned To: Mark Finkle (:mfinkle) (use needinfo?)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-08 04:34 PST by Ioana Chiorean
Modified: 2011-08-18 10:34 PDT (History)
7 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
screenshot (117.98 KB, image/png)
2011-03-14 09:32 PDT, Ioana Chiorean
no flags Details
patch (2.20 KB, patch)
2011-08-13 13:58 PDT, Mark Finkle (:mfinkle) (use needinfo?)
mbrubeck: review+
Details | Diff | Splinter Review

Description Ioana Chiorean 2011-03-08 04:34:58 PST
Build id : Mozilla/5.0 (Maemo;Linux armv7l;rv:2.0b13pre)Gecko/20110308
Firefox/4.0b13pre Fennec /4.0b6pre
Device: Samsung Galaxy S Captivate
OS: Android 2.1 update 1

Precondition: Fennec is selected as the default browser 

Steps to reproduce:
1. go to the right panel
2. quit fennec by tapping the home button
3. click on a web link on any app of the system

Actual result:
- Fennec show up but with the right panel into view

Expected result: 
- Fennec show up and the main view with the opened url is displayed

Note: 
- bug 632346 is Verified Fixed
Comment 1 Aaron Train [:aaronmt] 2011-03-14 09:29:07 PDT
Ioana, can you post a screenshot?
Comment 2 Ioana Chiorean 2011-03-14 09:32:20 PDT
Created attachment 519164 [details]
screenshot

added screenshot.
Comment 3 Cristian Nicolae (:xti) 2011-03-23 10:42:18 PDT
This issue is still reproducing on:
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:2.2a1pre)Gecko/20110323
Firefox/4.0b13pre Fennec /4.1a1pre
Device: Sony Ericsson Xperia X10
OS: Android 2.1 update 1
Comment 4 Ioana Chiorean 2011-05-12 04:29:30 PDT
This is a regression for bug 632346 https://bugzilla.mozilla.org/show_bug.cgi?id=632346. 

It's still reproduces on both builds:

Mozilla /5.0 (Android;Linux armv7l;rv:6.0a1) Gecko/20110511 Firefox/6.0a1 Fennec/6.0a1

Mozilla /5.0 (Android;Linux armv7l;rv:5.0a2) Gecko/20110511 Firefox/5.0a2 Fennec/5.0a2
Comment 5 Anna (Waverley) 2011-05-20 04:55:37 PDT
Also the TC in litmus: https://litmus.mozilla.org/show_test.cgi?id=13821 fails due to this bug 

Build Id: Mozilla /5.0 (Android;Linux armv7l;rv:6.0a1) Gecko/20110519 Firefox/6.0a1 Fennec/6.0a1
Comment 6 Mark Finkle (:mfinkle) (use needinfo?) 2011-07-25 10:43:26 PDT
Wes, can we just move the BrowserUI.hidePanel() calls to here:
http://mxr.mozilla.org/mozilla-central/source/mobile/chrome/content/browser.js#1660
Comment 7 Mark Finkle (:mfinkle) (use needinfo?) 2011-08-13 13:58:57 PDT
Created attachment 552900 [details] [diff] [review]
patch

This patch ensures that sidebars, tool panels and autocomplete panels are hidden when opening a new tab (or loading into an existing tab). We try to do the same thing in other places where we start loading content into a new or existing tab.
Comment 8 Mark Finkle (:mfinkle) (use needinfo?) 2011-08-13 17:21:32 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/c974f3df9ace
Comment 9 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-08-14 05:16:14 PDT
http://hg.mozilla.org/mozilla-central/rev/c974f3df9ace
Comment 10 Aaron Train [:aaronmt] 2011-08-15 06:13:06 PDT
Verified Fixed
Mozilla/5.0 (Android; Linux armv7l; rv:8.0a1) Gecko/20110815 Firefox/8.0a1 Fennec/8.0a1

Note You need to log in before you can comment on or make changes to this bug.