::after with 'content' prevents <select> drop-down selection

RESOLVED DUPLICATE of bug 464758

Status

()

RESOLVED DUPLICATE of bug 464758
8 years ago
8 years ago

People

(Reporter: GPHemsley, Unassigned)

Tracking

({css2, css3})

Trunk
x86
Mac OS X
css2, css3
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 517988 [details]
Reduced testcase with ::after and 'content' styling on <select>

If a <select> object has a styling on it using the CSS3 selector ::after (or even the CSS2 selector :after) and the attribute 'content', the <select> drop-down box cannot be used and you cannot make a selection. In particular, when you click on it, it drops down but immediately goes away.

In the original code where this was discovered, I was attempting to include an asterisk after every required element. I noticed at the time that the asterisk never showed up anywhere, but I thought I might have been Doing It Wrong™ and paid no further attention. I left the styling in and turned my attention towards other things, but it was later pointed out to me that the drop-down didn't work.

I've narrowed it down to the attached reduced testcase. (It's possible it could be reduced further.) I believe the person who originally discovered the issue was using Firefox 3.6, but I can reproduce it in 4.0rc1.

When I was constructing the testcase, I happened to right-click while the computer was catching up with the drop-down-and-back-up-again behavior, and I got this crash: bp-225a4af3-7254-41fd-9aea-fd89d2110308. I don't know if it's actually related, though.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 464758
You need to log in before you can comment on or make changes to this bug.