Closed Bug 640486 Opened 9 years ago Closed 9 years ago

<iframe> is empty (due to missing network request?)

Categories

(Core :: DOM: Navigation, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla5

People

(Reporter: celio.vibenna, Unassigned)

References

()

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

Web site http://www.carivit.it
Loading the page for the first time after Firefox was started, the box in right upper corner (the one used to input website credentials) is not shown. Refeshing the page, the box is shown correctly.
This doesn't happen with other browser (Safari, Chrome, older versions of Firefox)

Reproducible: Always

Steps to Reproduce:
1. Open Firefox
2. Go to http://www.carivit.it
3. Look at the upper right corner just below the website menu: the box is not shown
4. Refresh the page: the box is correcty shown 
Actual Results:  
The first time you visit the page, a part of the page is not shown; after refreshing, the page is completed

Expected Results:  
The page should be correctly shown at the first visit.
Same problem on Firefox 4.0 RC 1 for Windows.
Mozilla/5.0 (Windows NT 6.1; rv:2.0b13pre) Gecko/20110309 Firefox/4.0b13pre

Confirmed. The login credentials box is not shown when loading the page for the first time. Refreshing the page, loads the box.
I can reproduce the problem.  AFAICT, the <iframe> is empty because there
was no http(s) request made for it.  Using a debug build with
NSPR_LOG_MODULES=nsHttp:5,nsStandardURL:5,nsSocketTransport:5,nsDocShell:5;
I can see there's a nsStandardURL created for it, the URL is:
https://www.carivit.it/script/Login2Servlet?dnsFrom=www.carivit.it&function=loginOtpBox&funzione=HPP

Shortly thereafter there is:
nsDocShell[7fffca3c3400]: loading https://www.carivit.it/script/Login2Servlet?dnsFrom=www.carivit.it&function=loginOtpBox&funzione=HPP with flags 0x00000000
nsDocShell[7fffca3c3400]: loading from session history
WARNING: NS_ENSURE_TRUE(shell) failed: file nsDocShell.cpp, line 10799
WARNING: NS_ENSURE_TRUE(sf) failed: file nsDocShell.cpp, line 4992
WARNING: NS_ENSURE_TRUE(shell) failed: file nsDocShell.cpp, line 10799
WARNING: NS_ENSURE_TRUE(sf) failed: file nsDocShell.cpp, line 4992
Destroying nsStandardURL @7fffc5105f00

AFAICT (sniffing the wire) there is no outgoing request for it.
The line "loading from session history" seems odd since I was using a
fresh profile.

The markup is:
<iframe id="ifrmloginweb20" scrolling="no" src="https://www.carivit.it/script/Login2Servlet?dnsFrom=www.carivit.it&function=loginOtpBox&funzione=HPP" frameborder="no" marginheight="0" marginwidth="0" height="237" width="205" style="margin-top: 0px; margin-left: 0px; border: 0 solid #000000;"><span>Errata visualizzazione delle login</span></iframe>
Severity: minor → normal
OS: Mac OS X → All
Hardware: x86 → All
Summary: Page not always rendered correctly → <iframe> is empty (due to missing network request?)
Regression range:  2010-08-20-03 -- 2010-08-21-03
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c8c886655ea1&tochange=5c5c3bf8dfeb
An additional observation is that loading the URL in the 2010-08-20 build
is a lot smoother than in later builds where the content "jumps around"
while the page loads.
Keywords: regression
Backing out bug 588643 appears to fix it.
Blocks: 588643
Status: UNCONFIRMED → NEW
Component: General → Document Navigation
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → docshell
Version: unspecified → Trunk
Does Bug 632835 fix this?
> Does Bug 632835 fix this?

Yes, I can't reproduce it with that patch and easily without it.
Depends on: 632835
Fixed by bug 632835.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.2
You need to log in before you can comment on or make changes to this bug.