showdown-highlight page rendering funny

RESOLVED FIXED in mozilla5

Status

()

defect
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: dherman, Assigned: mattwoodrow)

Tracking

unspecified
mozilla5
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(4 attachments, 1 obsolete attachment)

This page:

    http://softwaremaniacs.org/playground/showdown-highlight/

is rendering funny on my MacBook Pro with hardware acceleration enabled, both in the nightly and RC. Attaching a screen shot. It self-corrects after a couple seconds or after some slight interaction like moving the mouse or clicking. Disabling hardware acceleration fixes it.

Don't know if it's relevant, but the web console spits out the warning about document.write() creating an unbalanced tree.

Dave
The broken rendering appears to be connected with scrolling. (Note that when the page loads, it scrolls the left-hand (source) pane to the bottom.) If I hit Command-R to reload at that point, nothing untoward happens; but if I scroll the left-hand pane back to the top, and then hit Command-R, the rendering problem (where content of the right-hand pane is blitted to the left-hand one) happens again.
scrolling sounds like layers
Further observation: the problem only occurs on Reload if the left-hand pane is scrolled _ALL_ the way to the top; if I adjust its scroll position even just a couple of pixels from the top, and then Reload, it scrolls cleanly to the bottom with no rendering artifacts.
Works: 2011-01-17 (66addc5c30ca)
Fails: 2011-01-18 (eb105fe0e41c)

Regression range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=66addc5c30ca&tochange=eb105fe0e41c
Specifically, this is a regression from 31b46f48f714 (bug 621778).
Assignee: nobody → matt.woodrow+bugzilla
Blocks: 642594
Posted patch Alternate fix (obsolete) — Splinter Review
I think I like this one better, it makes the texture state clearer than having two bool vars.
Attachment #520383 - Flags: review?(joe)
Actually qref the changes
Attachment #520383 - Attachment is obsolete: true
Attachment #520383 - Flags: review?(joe)
Attachment #520387 - Flags: review?(joe)
Comment on attachment 520381 [details] [diff] [review]
Upload the full surface if the texture contents are uninitialized

agreed - the enumerated type is better.
Attachment #520381 - Flags: review?(joe) → review-
Comment on attachment 520387 [details] [diff] [review]
Alternate fix v2

Would love to see a test.
Attachment #520387 - Flags: review?(joe) → review+
Landed the fix as: http://hg.mozilla.org/mozilla-central/rev/5cd1f196e421

Will try write a test for this today.
Attachment #524256 - Flags: review?(joe) → review+
http://hg.mozilla.org/mozilla-central/rev/c2242c63e75f
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.2
Duplicate of this bug: 642594
You need to log in before you can comment on or make changes to this bug.