Per-OS top crashers lists

VERIFIED FIXED in 2.4.2

Status

Socorro
Webapp
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: bjacob, Assigned: espressive)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Q42011wanted] [Q12012wanted])

Attachments

(2 attachments)

Of course the top crash signatures are all Windows specific. So if I'm looking at them to see if a certain feature is crashing a lot, I can get the impression that everything is fine until I realize that it's crashing only on Mac/Linux, just not quite enough to beat the major Windows crashers.

I would suggest making the current top crashers list Windows-only (that's almost what it already unofficialy is) and adding other OSes below.

Comment 1

7 years ago
Wait for 1.9 to see if we can do this with ES.
Target Milestone: --- → 1.9

Updated

7 years ago
Target Milestone: 1.9 → 2.0

Comment 2

7 years ago
Lars: take this into account for killwolf, but lower priority (it can wait).
Assignee: nobody → lars

Updated

7 years ago
Assignee: lars → bsavage
Target Milestone: 2.0 → 2.1

Updated

7 years ago
Target Milestone: 2.1 → 2.0
Per Lars, pushing off to next release.
Assignee: bsavage → nobody
Target Milestone: 2.0 → 2.1

Updated

7 years ago
Target Milestone: 2.1 → 2.2

Updated

7 years ago
Target Milestone: 2.2 → 2.3
Target Milestone: 2.3 → 2.3.1

Updated

7 years ago
Target Milestone: 2.3.1 → 2.3.2

Comment 4

7 years ago
Rob, I'd like to know how hard this is going to be (and then triage it more intelligently).  Can you take a look?

Updated

7 years ago
Whiteboard: Q42011wanted

Updated

7 years ago
Target Milestone: 2.3.2 → ---
(Assignee)

Comment 5

7 years ago
Reading [:bjacob] comment, it seems that what is needed is to take the table that is currently displayed here https://crash-stats.mozilla.com/topcrasher/byversion/Firefox/3.5.13 and split it to be two seperate tables.

One showing only Windows crashes and the other non-Windows related crashes. Do I understand this correctly?
(Reporter)

Comment 6

7 years ago
Not sure: for examples, the volume of Mac crashes would probably still dwarf the volume of Linux crashes. I really think we need per-OS top-crashers-views, for each OS.
(Assignee)

Comment 7

7 years ago
[:bjacob] Makes sense, would like to also hear what KaiRo thinks about it.

Comment 8

7 years ago
If we would have a parameter to call this page (linked somewhere reasonable) that makes us show the list for a single OS, I think we would have all we want. This would be similar to what we have for browser/plugin/content/all versions of those reports.
(Assignee)

Comment 9

7 years ago
Looking at the call to the web service for the topcrasher.php controller, it needs to be extended to also allow for an optional OS string to be passed:

Currently:
$resp = $service->get("${host}/topcrash/sig/trend/rank/p/${p}/v/${v}/type/${crash_type}/end/${end_date}/duration/${dur}/listsize/${limit}", 'json', $lifetime);

Extended:
$resp = $service->get("${host}/topcrash/sig/trend/rank/p/${p}/v/${v}/type/${crash_type}/end/${end_date}/duration/${dur}/listsize/${limit}/os/${os}", 'json', $lifetime);

I suppose one can also filter the response but, it might be better to do this on the DB side already. If an OS is not provided the service can simply return the result for all OS's as it currently does.
(Assignee)

Updated

7 years ago
Duplicate of this bug: 427588
Adrian, can you add the appropriate params to the m'ware call and then pass back over to Schalk?
Assignee: nobody → adrian

Updated

6 years ago
Whiteboard: Q42011wanted → [Q42011wanted] [Q12012wanted]
Depends on: 713871

Updated

6 years ago
Target Milestone: --- → 2.4.1
Component: Socorro → General
Product: Webtools → Socorro

Updated

6 years ago
Component: General → Webapp
I think my part of the job is done: https://github.com/AdrianGaudebert/socorro/tree/641487-per-os-tcbs-2

Schalk, I'm passing the baby to you. Let me know if there's anything I need to do.
Assignee: adrian → sneethling
(Assignee)

Updated

6 years ago
Target Milestone: 2.4.1 → 2.4.2
(Assignee)

Comment 13

6 years ago
[:kairo] One question regarding per os tcbs. When selecting the OS, does the product version fall away or should the results then still be for the currently selected version, just filtered further by the selected OS?
Schalk: the latter.

Comment 15

6 years ago
As Laura also says, it should act like the process type selector does as well and keep all other options intact. That is, when looking at topcrashers for Firefox 10.0b5, I expect that clicking "Linux" in a platform selector will take me to Firefox 10.0b5 Linux topcrashers, clicking "Mac" will take me to FF 10.0b5 Mac TCBS, and "All" (or so) will take me back to the total FF 10.0b5 TCBS page.
(Assignee)

Comment 16

6 years ago
Created attachment 594728 [details]
per os top crashers

This is where I am at currently, everything works, just have some more tweaks I want to make that can be filtered into the other areas if it proves good.
(Assignee)

Comment 17

6 years ago
Sent pull request: https://github.com/mozilla/socorro/pull/332

Test case coming soon.
This should be able to be done using the existing TCBS table without any new database support.

Comment 19

6 years ago
Commit pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/3e0e85246666f21f4b847d9cb3cec17909ea363c
Merge pull request #332 from ossreleasefeed/per-os-tcbs

Per os tcbs fixes bug 641487

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(In reply to [github robot] from comment #19)
> Commit pushed to master at https://github.com/mozilla/socorro
> 
> https://github.com/mozilla/socorro/commit/
> 3e0e85246666f21f4b847d9cb3cec17909ea363c
> Merge pull request #332 from ossreleasefeed/per-os-tcbs
> 
> Per os tcbs fixes bug 641487

BTW the three config files in this changeset need to be merged to stage config, so I have added an entry to https://wiki.mozilla.org/Socorro:Releases/2.4.2#config_changes 

topcrashers.php
platforms.php
routes.php

crash-stats-dev selectively overrides so it doesn't break there; we should either make stage and prod do the same, or make c-s-d always override so it breaks and we know :) will file a separate bug for that.
(Assignee)

Comment 21

6 years ago
TEST CASE
---------

Head to top crashers
Here there will be a new filter for OS containing:
Window Linux Mac OS X

Clicking on one of these will take you to the new per os top crashers page. The OS filter on this page will have one new addition called 'All'. Clicking on this will take you back to the top crashers page retaining the product, version, type and duration.

Back on the per os page, the content will be much the same as the current top crashers but, there are some columns that are not shows such as count. You should also see crash numbers only for the current selected OS.

Clicking on the different OS links will reload the page showing crashes only for that OS. The type and duration links should here work the same as they do on top crashers.

There are also some subtle UI changes to look out for here. The up and down trend is not shown as an up or down arrow next to the row and no longer on the trend column.

Opening a graph under signature will now show a different display as well as providing the option to close the graph. Once a graph has been closed, you should be presented again with the option to show the graph.

When sorting per column using the table sorter the rows should always retain their proper alternate row colors.

I believe this covers everything that needs to be checked however, if there is anything that seems odd or not work as expected, please let me know.
Created attachment 596228 [details]
qa - verified

Bumping to qa verified. Thanks sckulk for the excellent description of what behavior changed in the app, comment 21.

:austind and I will file some feature enhancement bugs based off of the conversation in the channel.

Updated

6 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.