If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Auto-publisher broken due to Collections API error

RESOLVED FIXED in 6.0.2

Status

addons.mozilla.org Graveyard
API
P1
critical
RESOLVED FIXED
7 years ago
2 years ago

People

(Reporter: mackers, Assigned: davedash)

Tracking

unspecified
6.0.2

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-GB; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
Build Identifier: 

The auto-publisher feature of the Collector extension is not working correctly due to an API error.

Reproducible: Always

Steps to Reproduce:
1. create an auto publisher
2. wait for collections to sync or restart firefox

Actual Results:  
The auto-publisher collection is created, but no extensions are added to the collection.

Expected Results:  
The auto-publisher collection is created and locally installed extensions are added to it.

This appears to be an API bug. The collector follows the API as specified in:

https://developer.mozilla.org/en/addons.mozilla.org_%28AMO%29_API_Developers%27_Guide/The_Bandwagon_API#Adding_an_addon_to_a_collection

Here is the debug output:

bandwagon(DEBUG): [API] send: opening POST XMLHttpRequest to https://addons.mozilla.org/en-US/firefox/api/1.3/sharing//collections/ae57a1d1-6fe0-b50b-1c22-b39e7474b25c/addons/?guid=%7B2522f048-c952-d742-8979-6f7206c86c70%7D&comments=&__=1300158328534

bandwagon(DEBUG): [API] send: completed, response text = '<?xml version="1.0" encoding="utf-8" ?>
<error xmlns="http://addons.mozilla.org/" 
    reason="invalid_parameters"
    details="" 
     
/>
 

Note that this API call used to work (upon previous collector release) - I don't think the format of the API call has changed on the client side since then.

Comment 1

7 years ago
Escalating this issue as a blocker to the imminent Collector release for Firefox 4.
Assignee: nobody → dd
Severity: normal → critical
Status: UNCONFIRMED → NEW
Component: Collector Extension → API
Ever confirmed: true
Priority: -- → P1
QA Contact: collector-extension → api
Summary: [Collector] Auto-publisher broken due to API error → Auto-publisher broken due to Collections API error
Can you explain the call to me:

 https://addons.mozilla.org/en-US/firefox/api/1.3/sharing//collections/ae57a1d1-6fe0-b50b-1c22-b39e7474b25c/addons/?guid=%7B2522f048-c952-d742-8979-6f7206c86c70%7D&comments=&__=1300158328534

what is the ae57... UUID and what is the {2522f048- uuid?

I'll try to piece together what I can.
(Reporter)

Comment 3

7 years ago
The call follows the Bandwagon API call to add an addon to a collection. See:

https://developer.mozilla.org/en/addons.mozilla.org_%28AMO%29_API_Developers%27_Guide/The_Bandwagon_API#Adding_an_addon_to_a_collection

In this case:

ae57a1d1-6fe0-b50b-1c22-b39e7474b25c is the collection
{2522f048-c952-d742-8979-6f7206c86c70} is the addon

Updated

7 years ago
Blocks: 626504
Where can I get the build of collector that you are using.

Ping me on IRC, this bug is a rabbit-hole for me, as I'd need to figure out some details with the collector in addition to getting remora set up locally, so I can figure out what's going on.

Comment 5

7 years ago
(In reply to comment #4)
> Where can I get the build of collector that you are using.

Sent via email.
This is the only thing in the way of releasing the Collector update for Firefox 4. We should push this today.
Brian - I didn't get it - try sending it to my personal email - dd@davedash.com.
If either of you are on IRC today that would probably help me a lot.
Brian, can you get online?

Fwiw, it doesn't sound like this is going to make our push, which goes out in 2 hours.
Target Milestone: --- → 6.0.2
(In reply to comment #7)
> Brian - I didn't get it - try sending it to my personal email -
> dd@davedash.com.

Done.
Brian, Dave and I are able to publish with our auto-publishers. Can you describe what the problem is in more detail or get on irc?
David,

It seems like everything is working except this display of the collection after first creation. Can you confirm? It displays after a refresh.
(Reporter)

Comment 13

7 years ago
Ok, the auto-published is working for me now. I see my extensions in the auto publisher collection. Not sure why it wasn't working before.

The "invalid_parameters" error was a slightly separate issue caused by the extension attempting to publish plugins. I've fixed that in r85492.

Brian, the issue with the extensions not appearing immediately has always been an issue AFAIR - maybe due to some server delay or caching? We could open a separate bug to track that.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(In reply to comment #13)
> Brian, the issue with the extensions not appearing immediately has always been
> an issue AFAIR - maybe due to some server delay or caching? We could open a
> separate bug to track that.

Bug 642881.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.