JM: Assertion failure: Call site vanished., at ./methodjit/Compiler.cpp:2467

RESOLVED DUPLICATE of bug 641535

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 641535
7 years ago
7 years ago

People

(Reporter: decoder, Unassigned)

Tracking

(Blocks: 2 bugs, {assertion, testcase})

Trunk
x86_64
Linux
assertion, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
The following test case (run -n -a -m) causes the assertion on JM tip (tested on 64 bit):

Array.prototype[1] = 'bar';
var a = []; 
a[__lookupSetter__[1]]='foo'; 


This could be related to 641535 but I'm not sure if it's the same.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 641535
(Reporter)

Updated

7 years ago
Blocks: 676763
You need to log in before you can comment on or make changes to this bug.