WebifyMe - Document Goals and Measurements

RESOLVED FIXED in 1.0

Status

Websites
webifyme.org
P1
normal
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: ryansnyder, Assigned: grace)

Tracking

unspecified
Dependency tree / graph

Details

Before the WebifyMe campaign launches, let's document how we will measure the campaign.

* What are the goals for this campaign?
* How do we plan to measure this campaign?
* How will we determine whether this campaign was a success?
* When do we need to schedule a post-mortem for this project?
Assignee: nobody → mayumi

Updated

7 years ago
Assignee: mayumi → chandler

Comment 1

7 years ago
* What are the goals for this campaign?
1.) Drive Firefox 4 Downloads
2.) Drive Firefox Newsletter sign-ups 
3.) # of collages created 
* How do we plan to measure this campaign?
1.) Conversion tracking on downloads
2.) Total number of newsletter sign-ups tracked through Responsys 
* How will we determine whether this campaign was a success?
It will be determined by the numbers in which there should be 1+MM pageviews, 100+K downloads and 50+K newsletter sign-ups but also want to see this on social media and it spreading via Facebook/Twitter
* When do we need to schedule a post-mortem for this project?
Ideally 1-2 weeks after the campaign is shut down

Updated

7 years ago
Blocks: 642353

Updated

7 years ago
Duplicate of this bug: 646688
Blocks: 651654

Updated

7 years ago
Priority: -- → P1
Target Milestone: --- → 1.0

Comment 3

7 years ago
Ryan, does Mayumi adequately answer this question, can we close this?

Updated

7 years ago
Assignee: chandler → ryansnyder.me+bugs

Comment 4

7 years ago
I think so, marking fixed.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Reopening since these goals were set in March and should be updated. Handing to Grace for now.
Assignee: ryansnyder.me+bugs → gjimenez
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Depends on: 679899
Depends on: 679920
Depends on: 681770

Updated

6 years ago
Depends on: 681788

Comment 6

6 years ago
Is this bug about just setting the goals, or producing the data, putting together the post mortem to learn from what went on during the campaign?

There is some good data about parts of the funnel in https://bugzilla.mozilla.org/show_bug.cgi?id=681788#c54 but its not complete.

We could also a a bit of data to understand metrics on the level of localization effort on the front end of the project from  https://localize.mozilla.org/de/

A more comprehensive overview taking the DE localization as an example might look like.

DE
Length and Expense of 
  Campaign Development
Strings Translated              5295 (~equal to the tl of SUMO or MDN Site Infra)
Length of Campaign             about 1 month
Quiz Takers                   111511  pct of all takers
Quiz Finishers                 43844  39%  (61% drop off rate)
de e-mail addresses gathered       ?
downloads                          ?
users acquired                     ?

Comment 7

6 years ago
> Quiz Takers                   111511  pct of all takers

should have read

Quiz Takers                   111511  (7% pct of quiz takers across all locales)

Comment 8

6 years ago
Webifyme is retired.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago6 years ago
Resolution: --- → FIXED

Comment 9

6 years ago
where are the results of the post campaign analsysis posted?

Comment 10

6 years ago
Chris: bottom of this blog post: http://blog.mozilla.com/website-archive/2011/11/15/webify-me/

Comment 11

6 years ago
I just checked Webtrends and the campaign accounted for 7,000 downloads of Firefox, which is 0.1% of all Firefox downloads between August 15th to Nov 21st 2011.

Comment 12

6 years ago
Just to clarify:

Goal:

* 100k+ downloads
* 50k email signups
* 1M collages

Actual:

* 7k downloads (.7% of goal)
* 242,133 email signups (484% of goal)
* 1M collages (100% of goal)

Conclusion:

* Email signups were substantially higher then the original goal and probably due to the opt-in being directly within the conversion workflow of creating a collage.
* The FF downloads were substantially lower then plan and more likely due to the download link being at the bottom of every page.

Comment 13

6 years ago
 (In reply to Chris More [:cmore] from comment #10)
> Chris: bottom of this blog post:
> http://blog.mozilla.com/website-archive/2011/11/15/webify-me/

That is a great summary with lots a good data.
Its exactly the kind of feedback that localizers are looking for 
to understand the value of their work, an start to get
a better understanding of which kinds of campaigns work,
and which don't, in their region.

It would be a good idea to post a link to that blog post in 
 http://groups.google.com/group/mozilla.dev.l10n.web
You need to log in before you can comment on or make changes to this bug.