A gender (sex) field for contact in address book

NEW
Unassigned

Status

Thunderbird
Address Book
--
enhancement
7 years ago
2 years ago

People

(Reporter: 石庭豐 (Seak, Teng-Fong), Unassigned)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
As of TB 3, contacts in address book don't have gender (sex) field.  So, let me suggest one.

Here are some proposed values:
0: (empty/not defined)
1: Male
2: Female
3: Not Applicable

Values instead of string should be used so that text can be localized, eg Male for English, Mâle for French, 男性 for Chinese, etc.

Value 3 (Not Applicable) is useful for non-personal contacts like companies.

To be politically correct or for better search results, we could also have two more values:
4: Changed to male
5: Changed to female
Summary: RFE: A gender (sex) field for contact in address book → A gender (sex) field for contact in address book
see bug #266891 comment 33#
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 266891
(Reporter)

Comment 2

7 years ago
Bug 266891 can not be marked as a duplicate of this one: it's not unclear if its comment #33 is taken seriously in that bug.  On the other hand, even if it will be considered seriously in the future, the whole bug can only be considered as a blocking bug to this one.

Please consider carefully in the futre before marking anything as duplicate just to reduce the number of effective bugs.
(Reporter)

Updated

7 years ago
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Updated

7 years ago
Depends on: 266891

Comment 3

6 years ago
I am the developer of the add-on Mail Merge (https://addons.mozilla.org/addon/mail-merge).

Mail Merge supports the addressbook and supports variables, e.g.: {{Sex|m|Mr.}}{{Sex|f|Mrs.}} could be used for an individual salutation based on the gender of the recipient.

Obviously this is not possible with the addressboook at the moment, because there is no gender field in the addressbook card. Therefore my users have to use Custom1 to Custom4 as a replacement for the missing gender field.

If you add a gender field to the addressbook card, this will be very helpful to my users!
This is an obvious omission which could/should be fixed even before arrival of the new AB because we never know when that will happen. This should be possible without too much hassle, although the devil might be in the detail for things like exporting, synchronizing etc.
Status: REOPENED → NEW
You need to log in before you can comment on or make changes to this bug.