updates builder shouldn't fail when config files have been bumped

RESOLVED FIXED

Status

Release Engineering
Release Automation: Other
P4
normal
RESOLVED FIXED
7 years ago
2 years ago

People

(Reporter: bhearsum, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [releases][automation])

(Reporter)

Description

7 years ago
the updates builder currently fails if it has no update verify bumping to do. as long as the update-verify-bump.pl script exited successfully, it should continue even if there's onthing to commit. I think we can do this by:
- setting flunkOnFailure/haltOnFailure=True for the bumping
- setting haltOnFailure=False for the commit/push

Not sure what to do about the builder turning red still in those cases. Maybe we need to use doStepIf?
Blocks: 627271
Whiteboard: [releases][automation]

Updated

7 years ago
Priority: -- → P4
Hardware: x86_64 → All
(Reporter)

Comment 1

6 years ago
Mass move of bugs to Release Automation component.
Component: Release Engineering → Release Engineering: Automation (Release Automation)
(Reporter)

Updated

6 years ago
No longer blocks: 714371
(Reporter)

Updated

6 years ago
Duplicate of this bug: 746607
(Reporter)

Comment 3

6 years ago
This is a bit tougher than I thought because a) there's no way I can find to create a commit without any changes on a modern hg, and b) "hg push" returns non-zero when there's nothing to push.

The best I can come up with is adding supporting for skipping bumping when a certain property is set. This isn't quite as good, because it means you need to know upfront that there won't be any changes necessary, but it's better than the current state. (Worst case scenario, you try rerunning updates, it fails because it didn't bump anything, you rerun it again with the property set). To implement this, we need to:
* Add a method that checks to see if "skipBump" exists (see https://github.com/mozilla/buildbotcustom/blob/master/process/factory.py#L2224 for a similar method), and returns False if it does.
* Pass that method to all of the BuildStep's in the bumpConfigs method: https://github.com/mozilla/buildbotcustom/blob/72d08bd748b9d71a85a1fbef2e0a06b1d488824b/process/factory.py#L4187
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
fixed in release promotion
Status: NEW → RESOLVED
Last Resolved: 2 years ago
QA Contact: bhearsum
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.