Closed Bug 643135 Opened 10 years ago Closed 7 years ago
Cleanup confusion over console node, hud box and output node
Currently the HUDService code is really confusing in its use of variable names for different nodes. Situation: - we have the main Web Console container element which is a xul:vbox with class name .hud-box. - we have the Web Console output container element is a xul:richlistbox element with class .hud-output-node. The code uses consoleNode, hudBox and outputNode to refer to any of the two elements. We also have methods that accept both elements as arguments ... perhaps we shouldn't.
Component: Developer Tools → Developer Tools: Console
QA Contact: developer.tools → developer.tools.console
is this still relevant?
Priority: -- → P3
Yes, unfortunately. It's no longer confusing for me (I'm used to it), and it has been greatly reduced with the patches I've been doing lately. The final blow will be the output rewrite.
Output rewrite work has fixed this. I cant point to one particular bug that fixed this.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.