Bug 778766 (console-output)

[meta] Web Console output work

RESOLVED INVALID

Status

defect
P3
normal
RESOLVED INVALID
7 years ago
7 months ago

People

(Reporter: msucan, Unassigned)

Tracking

(Depends on 9 bugs, Blocks 1 bug, {meta})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [status:inflight], )

Reporter

Description

7 years ago
We want to be able to fix bug 706755 and bug 775607. We want to make it easier to add new message types and to customize the existing messages in the Web Console output. Since the last output rewrite in bug 605621, the output implementation has become harder to manage and easy to break (prone to regressions).

A rewrite is in order with the aforementioned goals. We also need to make sure that we improve message filtering performance and that we make it less confusing how filtering, categories and severities work.

This bug will only change the implementation while keeping user experience changes to a minimum. We need to be able to easily track potential regressions. The rest of the work will happen in separate bugs.

Other related bugs: bug 628019, bug 637604 and 617698.
I think this bug relates to bug 673891.
Reporter

Comment 2

7 years ago
Ohzeki: you are correct. Thanks for your find! I missed that bug.

What I am working on will allow easy lookup of nodes within a message, but instead of using XBL, messages will be represented by JS objects.
Alias: console-output
Depends on: 800510
Depends on: 801067
Depends on: 584733
Reporter

Updated

7 years ago
Blocks: 588010
Depends on: 632543
Depends on: 653710
Depends on: 666723
Depends on: 674422
Depends on: 682033
Depends on: 685813
Depends on: 773291
Reporter

Updated

7 years ago
Depends on: 746872
Reporter

Updated

7 years ago
Depends on: 628019
Depends on: 792633
Depends on: 581352
Reporter

Updated

7 years ago
Depends on: 592523
Reporter

Updated

7 years ago
Blocks: 704110
Reporter

Updated

7 years ago
Blocks: 690715
Reporter

Updated

7 years ago
Blocks: 826078
Depends on: 725771
Reporter

Updated

7 years ago
Depends on: 835951
Reporter

Updated

7 years ago
Depends on: 720180
Reporter

Updated

7 years ago
Depends on: 837774
Reporter

Updated

7 years ago
Depends on: 643135
Reporter

Updated

6 years ago
Depends on: 843004
Depends on: 814497
Reporter

Updated

6 years ago
Depends on: 844637
Reporter

Updated

6 years ago
Depends on: 847303
Reporter

Updated

6 years ago
Depends on: 705921
Reporter

Updated

6 years ago
Depends on: 793996
Depends on: 639800
Depends on: 655700
Depends on: 660197
Depends on: 663370
Depends on: 675487
Reporter

Updated

6 years ago
Depends on: 684096
Reporter

Updated

6 years ago
Depends on: 859841
Reporter

Updated

6 years ago
Depends on: 712553
Reporter

Updated

6 years ago
Blocks: 760876
Reporter

Updated

6 years ago
Depends on: 704252
Reporter

Updated

6 years ago
Depends on: 746871
Reporter

Updated

6 years ago
Depends on: 746870
Reporter

Updated

6 years ago
Depends on: 760824
Reporter

Updated

6 years ago
Depends on: 755534
Reporter

Updated

6 years ago
Blocks: 722267
Reporter

Updated

6 years ago
Depends on: 790309
Reporter

Updated

6 years ago
Depends on: 724224
Reporter

Updated

6 years ago
Depends on: 762321
Reporter

Updated

6 years ago
Depends on: 776939
Reporter

Updated

6 years ago
Depends on: 696385
Reporter

Updated

6 years ago
Blocks: 864934
Reporter

Updated

6 years ago
Blocks: 865288
Reporter

Updated

6 years ago
Blocks: 865694
Reporter

Updated

6 years ago
Blocks: 865708
Reporter

Comment 3

6 years ago
We have started work on fixing this bug. Actual patches will be submitted in specific bugs.

The plan is here: https://gist.github.com/mihaisucan/5399023

Feedback is welcome. Thank you!
Summary: Web Console output rewrite → [meta] Web Console output rewrite
Reporter

Updated

6 years ago
Blocks: 867182
Reporter

Updated

6 years ago
Blocks: 872060
Reporter

Updated

6 years ago
Depends on: 874591
Reporter

Updated

6 years ago
Blocks: 755555
Reporter

Updated

6 years ago
Depends on: 879310
Reporter

Updated

6 years ago
Depends on: 880861
Reporter

Updated

6 years ago
Blocks: 884059
Reporter

Updated

6 years ago
Blocks: 886157
Reporter

Updated

6 years ago
No longer depends on: 724224
Reporter

Updated

6 years ago
Blocks: 675487
No longer depends on: 675487
Reporter

Updated

6 years ago
Blocks: 628019
No longer depends on: 628019
Reporter

Updated

6 years ago
Blocks: 773291
No longer depends on: 773291
Reporter

Updated

6 years ago
No longer depends on: 844637
Reporter

Updated

6 years ago
Depends on: 878519
Reporter

Updated

6 years ago
Blocks: 874591
No longer depends on: 874591
Reporter

Updated

6 years ago
Blocks: 903676

Updated

6 years ago
Depends on: 870487

Updated

6 years ago
No longer depends on: 870487
Reporter

Updated

6 years ago
Blocks: 899753
Depends on: 909750
Depends on: 909754
Depends on: 909756
Reporter

Updated

6 years ago
Blocks: 914108
Reporter

Updated

6 years ago
Depends on: 920116
Reporter

Updated

6 years ago
Depends on: 923281
Reporter

Updated

6 years ago
Depends on: 757866
Duplicate of this bug: 922758
Reporter

Updated

6 years ago
Depends on: 944048
Reporter

Updated

6 years ago
Blocks: 584733
No longer depends on: 584733
Depends on: 972530
Reporter

Updated

5 years ago
Depends on: 973370
Reporter

Updated

5 years ago
No longer depends on: 757866
Reporter

Updated

5 years ago
No longer depends on: 682033
Reporter

Updated

5 years ago
Depends on: 982456
Reporter

Updated

5 years ago
Depends on: 983473
Reporter

Updated

5 years ago
Depends on: 977586
Reporter

Updated

5 years ago
Depends on: 987920
Reporter

Updated

5 years ago
Depends on: 976715
Reporter

Updated

5 years ago
Depends on: 948878
Reporter

Updated

5 years ago
Depends on: 1004752
Reporter

Updated

5 years ago
Blocks: 1005724
Reporter

Updated

5 years ago
Depends on: 1021337
Reporter

Updated

5 years ago
Depends on: 1021925
aiui, most of the important stuff has been taken care of. Do we still want to complete the remaining dependent bugs or can we close this meta bug and consider it "completed"?
Whiteboard: [status:inflight]
Reporter

Comment 6

5 years ago
(In reply to Rob Campbell [:rc] (:robcee) from comment #5)
> aiui, most of the important stuff has been taken care of. Do we still want
> to complete the remaining dependent bugs or can we close this meta bug and
> consider it "completed"?

Indeed, the most important bugs are fixed. However this meta bug continues to be useful for me, to keep track of console output work. Maybe rename the bug?
Summary: [meta] Web Console output rewrite → [meta] Web Console output work
Assignee: mihai.sucan → nobody
Status: ASSIGNED → NEW
Depends on: 1102797
Depends on: 905978
Depends on: 1255311
Priority: P1 → P3

Updated

Last year
Product: Firefox → DevTools
This was about old console, we can close this
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.