the toolbar bordering content looses its bottom border when "tabs on top" and "always show the tab bar" are unchecked

RESOLVED WORKSFORME

Status

()

Firefox
Theme
--
trivial
RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: al_9x, Unassigned)

Tracking

Trunk
All
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.15) Gecko/20110303 Firefox/3.6.15
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

a well defined border is needed to separate chrome from content

Reproducible: Always

Steps to Reproduce:
1. new 4.0rc2 profile 
2. note that the main toolbar has a bottom border
3. uncheck Options->Tabs->"Always show the tab bar"
4. uncheck "Tabs on top" in the toolbar context menu
5. the main toolbar looses its bottom border

this also happens when other toolbars are bordering content (bookmarks toolbar, custom toolbar)

Comment 1

7 years ago
Confirmed on Windows7 Aero/Classic , Windows XP Luna/Classic and Linux.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b13pre) Gecko/20110319 Firefox/4.0b13pre ID:20110319030418

Mozilla/5.0 (X11; Linux i686; rv:2.0b13pre) Gecko/20110319 Firefox/4.0b13pre ID:20110319030418
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Version: unspecified → Trunk
(Reporter)

Updated

7 years ago
Summary: the toolbar bordering content looses it's bottom border when "tabs on top" and "always show the tab bar" are unchecked → the toolbar bordering content looses its bottom border when "tabs on top" and "always show the tab bar" are unchecked
Component: Toolbars → Theme
QA Contact: toolbars → theme
(Reporter)

Comment 2

7 years ago
This is only a minor tweak, why couldn't it have been fixed for 4.0.1?
(Reporter)

Comment 3

7 years ago
It looks like 5.0 will be released without a fix, why?

Comment 4

7 years ago
al_9x@yahoo.com, if you have a bug that you think should be fixed for a particular release, you should try find the person who can work on it and cc: them on the bug. If that's too much work, you can ask on IRC and usually get a quick answer. If that's too much work, you can cc me and I'll take a look. 

As to why 5 will be released without this fix, the answer is simple. There is no fix here and 5 will be released on June 21. We don't hold releases for fixes. 

Dao, shorlander, or Margaret, do you know if this is already reported somewhere?

Comment 5

7 years ago
(I could have also noted that this is not critical bug given the small number of people who configure Firefox like that.)
(Reporter)

Comment 6

7 years ago
(In reply to comment #5)
> (I could have also noted that this is not critical bug given the small
> number of people who configure Firefox like that.)

I wouldn't say it's critical, but this configuration is not arbitrary or crazy, it could be called Firefox classic, that's the way it looked for years, and I would guess many prefer it, especially considering that the changes (tabs on top, always visible tab bar) don't really offer any benefits.  Anyway, this is a supported configuration, thankfully, and should not be (visually) broken.

There is still no comment from the Themes devs.  Considering this was reported 3 months ago, even before 4.0 was released, is it not reasonable to expect that this minor tweak could be made at least for the next release?

Well, that ship has sailed, how about 5.0.x?  6.0?
(Reporter)

Comment 7

7 years ago
@asa - you asked the theme people to comment, they still haven't and it's looking like this won't be fixed in 6.0 either.

Comment 8

7 years ago
I can't reproduce this issue on OSX or Windows 7, but maybe I just don't understand what the problem is. If you're still experiencing this issue, could you please elaborate on exactly what's going wrong?
I still see it on Windows 7 and as far as I know this issue isn't being tracked anywhere else.
(Reporter)

Comment 10

7 years ago
(In reply to comment #8)
> I can't reproduce this issue on OSX or Windows 7

I am on xp, but it looks like two other people have confirmed this on win7.

In the default case (new profile) do you see that main toolbar (whatever toolbar borders content) has a bottom border, that clearly separates browser chrome from the content area?

Now follow the directions from the description, do you still see that border?
(Reporter)

Comment 11

7 years ago
If you open a page with the same background color as the chrome ( about: )  the absence of the border will be more obvious.

Comment 12

7 years ago
You know, folks, a screenshot, especially an annotated one, would go a long ways describing what it is you're seeing.

Comment 13

7 years ago
I'm seeing it now, but I'm having trouble figuring out what style is creating the border in the tabs on top case. This situation is kind of odd because the navigation toolbar has no background or border with tabs on bottom, but because the tab strip is hidden, flipping the tabs on top pref is just changing the navigation toolbar style.

Dao and Frank have done the most work with tab strip/toolbar styles, so I think they would be the best people to know how to solve this problem. I don't think this is a very high priority issue because it takes a combination of two non-default prefs to get here, but maybe they know an easy solution.

Comment 14

7 years ago
Yes, very much agreed that this is not a high-priority given the low visibility of the don't show tabs pref and non-standard toolbar placement.
(Reporter)

Comment 15

7 years ago
(In reply to comment #13)
> I don't think this is a very high priority issue because it takes a
> combination of two non-default prefs to get here, but maybe they know an
> easy solution.

If one were randomly changing settings, this combination would indeed be rare, but as I pointed out, this is not an arbitrary/random/crazy configuration, it's the classic look of Fx, and those who don't like change for it's own sake, deliberate seek it out.  The always visible tab bar and tabs on top, do not offer any meaningful advantages, and in recognition of this fact, the classic look is supported with gui prefs, and so should not be neglected in the theme.

Comment 16

7 years ago
(In reply to comment #15)
> (In reply to comment #13)
> > I don't think this is a very high priority issue because it takes a
> > combination of two non-default prefs to get here, but maybe they know an
> > easy solution.
> 
> If one were randomly changing settings, this combination would indeed be
> rare, but as I pointed out, this is not an arbitrary/random/crazy
> configuration, it's the classic look of Fx, and those who don't like change
> for it's own sake, deliberate seek it out.  The always visible tab bar and
> tabs on top, do not offer any meaningful advantages, and in recognition of
> this fact, the classic look is supported with gui prefs, and so should not
> be neglected in the theme.

Al, your advocacy here, especially calling considered decisions by a very capable design team "change for its own sake" is not going to win friends or influence the direction of the product. This is a bug. It would be nice to fix all bugs. But this is not a high priority and you are not going to change that by insulting the feature changes or the people who have made those. If you'd like to continue this discussion, please email me and we'll talk there. Please do not continue commenting here unless you're adding new information. Thanks.
(Reporter)

Comment 18

7 years ago
Unless all work on the theme has stopped, is it really that much trouble to add a border?

Updated

6 years ago
Assignee: nobody → dao
Severity: normal → trivial

Updated

6 years ago
OS: All → Windows XP
Hardware: x86 → All

Updated

6 years ago
Duplicate of this bug: 755325
(In reply to al_9x from comment #0)
> 3. uncheck Options->Tabs->"Always show the tab bar"
> 4. uncheck "Tabs on top" in the toolbar context menu

These options don't exist anymore.
Assignee: dao → nobody
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.