Last Comment Bug 643233 - Popout window in Google Reader doesn't contain player
: Popout window in Google Reader doesn't contain player
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: ---
Assigned To: general
:
: Jason Orendorff [:jorendorff]
Mentors:
http://www.google.com/reader
Depends on: 637644
Blocks: 580128
  Show dependency treegraph
 
Reported: 2011-03-20 01:56 PDT by Balazs Attila-Mihaly
Modified: 2011-04-13 06:59 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Balazs Attila-Mihaly 2011-03-20 01:56:42 PDT
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

If you read a feed in Google Reader which has an MP3 attachment (like the feed for a podcast for example) you will see a flash player at the end of the article which allows you to play the file right there. There is also a "Popoup" link next to it which should open the player in a new window. This is not working (the new opened window is empty).

Details: I have the latest NoScript installed and google.com is enabled. I also have the following entry in my error console:

Error: Components.classes['@mozilla.org/extensions/manager;1'] is undefined
Source File: chrome://jqs/content/overlay.js
Line: 9

Warning: XUL box for _moz_generated_content_after element contained an inline #text child, forcing all its children to be wrapped in a block.
Source File: chrome://browser/content/browser.xul
Line: 0

And a lot of CSS warnings like the following:

Warning: Unknown property '-moz-opacity'.  Declaration dropped.
Source File: http://www.google.com/reader/ui/2490394466-en-scroll.css?hl=en
Line: 1

Reproducible: Always

Steps to Reproduce:
1. Log in to Google Reader
2. Open an article in a feed which has an MP3 linked to it (like a podcast)
3. Scroll down to the bottom of the article and click "Popout"
Actual Results:  
A new empty window opens

Expected Results:  
For a new window to open with the flash player in it.
Comment 1 Alice0775 White 2011-03-20 02:35:08 PDT
Confirmend on Windows7 and Ubuntu10.04
*Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b13pre) Gecko/20110319 Firefox/4.0b13pre ID:20110319030418
*Mozilla/5.0 (X11; Linux i686; rv:2.0b13pre) Gecko/20110319 Firefox/4.0b13pre ID:20110319030418

Smaple URL(Japanese) http://www.google.com/reader/view/feed/http%3A%2F%2Fwww.joqr.net%2Fblog%2Fkana%2Findex.xml#stream/feed%2Fhttp%3A%2F%2Fwww.joqr.net%2Fblog%2Fkana%2Findex.xml

Regression window(m-c hourly):
Works:
http://hg.mozilla.org/mozilla-central/rev/0c9ae492cf5f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101013 Firefox/4.0b8pre ID:20101013163957
Fails:
http://hg.mozilla.org/mozilla-central/rev/4c146ed860b3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101014 Firefox/4.0b8pre ID:20101014021111
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0c9ae492cf5f&tochange=4c146ed860b3

In local build(from m-c repository),
build from 29c228a4d7eb : fails
build from 335272ab0550 : fails
build from 659215248912 : works
build from 61cf1922e29d : forks
Triggered by Bug 580128
Comment 2 Alice0775 White 2011-03-20 22:06:21 PDT
Regression window on ubuntu10.04(tm nightly):
Works
http://hg.mozilla.org/tracemonkey/rev/edb0506b0c23
Mozilla/5.0 (X11; Linux i686; rv:2.0b8pre) Gecko/20101010 Firefox/4.0b8pre ID:20101010033459
Fails:
http://hg.mozilla.org/tracemonkey/rev/0a667876b6fd
Mozilla/5.0 (X11; Linux i686; rv:2.0b8pre) Gecko/20101011 Firefox/4.0b8pre ID:20101011034442
Pushlog
http://hg.mozilla.org/tracemonkey/pushloghtml?fromchange=edb0506b0c23&tochange=0a667876b6fd

In local build on ubuntu10.04(from tm repository)
build from 6c45f066ed17 : fails
build from d7f66f6eeda3 : build error
...
build from 5378adc0eb9f : build error
build from 659215248912 : works

Regressed between 5378adc0eb9f and 6c45f066ed17.
Comment 3 Alice0775 White 2011-04-13 06:49:30 PDT
http://www.google.com/reader/view/feed/http%3A%2F%2Fwww.joqr.net%2Fblog%2Fkana%2Findex.xml#stream/feed%2Fhttp%3A%2F%2Fwww.joqr.net%2Fblog%2Fkana%2Findex.xml

I can not reproduce the problem any more.
http://hg.mozilla.org/mozilla-central/rev/6bcaec19d09e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0a1) Gecko/20110413 Firefox/6.0a1 ID:20110413030543

Fixed range pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=200a746e0fac&tochange=906db7ecd063
Fixed by:
906db7ecd063	Boris Zbarsky — Bug 637644. Start layout on the new document we just created in nsGlobalWindow::SetOpenerScriptPrincipal, since if we don't do it here no one ever will. r=jst
Comment 4 Boris Zbarsky [:bz] (still a bit busy) 2011-04-13 06:59:04 PDT
That could do it, yes.  And that would explain the regression range too.

Note You need to log in before you can comment on or make changes to this bug.