Closed Bug 643240 Opened 9 years ago Closed 9 years ago

Can't open attached pdf or Word doc files that open normally in MS Outlook.

Categories

(Thunderbird :: General, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 92111

People

(Reporter: yudi.pawitan, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; sv-SE; rv:1.9.2.15) Gecko/20110303 Firefox/3.6.15 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.13) Gecko/20101207 Thunderbird/3.1.7

Both Adobe and Word complain that the attached files have been corrupted. But when we open the email in Outlook, the attached files will open normally.

When we save the attachment using Thunderbird, the problem persists. Saving using Outlook is fine. If we move the email to a subfolder in Thunderbird, then even Outlook cannot open the attachment. And in Thunderbird the content of the email is completely replaced by some other (random?) email!

This problem started occuring after our mail server was changed to Microsoft Exchange on 15th Feb 2011.

Reproducible: Sometimes

Steps to Reproduce:
1.Must have Thunderbird under Microsoft Exchange Server. 
2.Need to receive lots of different attachments of pdf or doc files. 

Actual Results:  
Some of those files should fail to open. (I can send sample files that fail, but this should happen many arbitrary files.)
This looks like bug 512693, which was resolved as a duplicate of bug 390795.
Whiteboard: dupeme?
(In reply to comment #1)
> Created attachment 520510 [details]
> A sample pdf file that fails to open as attachment (note: may not be a sure
> event).

Can you attach the complete email instead of the just a pdf file ?

(In reply to comment #2)
> This looks like bug 512693, which was resolved as a duplicate of bug 390795.

And to make sure of this we would also need an imap log (see https://wiki.mozilla.org/MailNews:Logging)
Comment #45 on bug 390795 solved it. 
On my current Thunderbird/3.1.7 for WinXP,
this works for me (so far):

Goto Tools>Options, click on 'Config Editor'.
On the search box type: fetch, you will see

mail.server.default.fetch_by_chunks 

with its current Value set to 'true'.
Right-click on the line, then click 'toggle' 
to change Value to 'false'.
Thanks for confirming, so it looks like the same issue. Since this appears to be clearly an MS Exchange server, duping to bug 92111 rather than bug 390795, if I understand the difference between those two bugs correctly.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupeme?
Duplicate of bug: 92111
You need to log in before you can comment on or make changes to this bug.