Can't delete / cut any event in the calendar - delete/cut/copy options are deactivated in context menu

RESOLVED WORKSFORME

Status

Calendar
Lightning Only
--
major
RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: Frank, Unassigned)

Tracking

(Blocks: 1 bug)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.15) Gecko/20110308 Fedora/3.6.15-1.fc14 Firefox/3.6.15
Build Identifier: Lightning/1.0b3pre Thunderbird/3.1.9

For deleting or moving an event, one right-clicks on the event and selects delete or cut or copy from the context menu. However, suddenly these options are always greyed out, and thus unavailable. I can't delete or cut/copy events any more. The calendar is not read-only (I checked the properties) and I still can create new events or modify events.

Reproducible: Always

Steps to Reproduce:
1. Right click on an event in the calendar
2. no delete /cut/copy options available
3.
Actual Results:  
Am not able to choose delete / cut / copy in the context menu

Expected Results:  
Should be able to choose delete / cut / copy in the context menu
I'll see this is fixed when working on bug 527254.
Blocks: 527254
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

7 years ago
Reading through bug 527254, I realized that despite the deactivated context menu options, keys still work. So simply using del, ctrl-x, ctr-c is an easy workaround.

Nonetheless, it's still a bug :-)
Frank, could you test this again with the latest nightly and identify the exact situation when the options are disabled? A such error can happen when the disabled state is not correctly updated on afocus change. Maybe this helps to find good steps to reproduce.

I could not reproduce this on my machine.
(Reporter)

Comment 4

7 years ago
Hi Philipp,

I'm using thunderbird-lightning-1.0-0.41.b3pre.fc15.x86_64 and
thunderbird-3.1.10-1.fc15.x86_64 . Please understand that I'm not updating with nightly builds - this is my machine at work, and I made bad experiences with incompatibilities bw. thunderbird and lightning, so I try to stay with the Fedora packaged builds.

The options are ALWAYS disabled. As described, above, keys still work.

Frank
Given the fedora package name is ...b3pre, it seems it is a random nightly build anyway. As things are always changing please understand that we cannot support older builds as we don't know if its fixed by now.

On the bright side, 1.0b4 is due this week, so you can take a look at that build :)
I have same problem.
I cannot delete event, DEL key isn't working, right click and Delete is grayed out (Cut also, but i can move event around with drag and drop).
Only way I can delete event is to double click it (edit event) and then press Delete button in toolbar.

Using WinXP, TB11 beta1 HR locale, Lightning 1.3beta1, caldav caledar connected with GroupOffice groupware.
Everything worked fine until I moved from TB10 to TB11 beta with beta Lightning.

Comment 7

6 years ago
Mihovil, the problem you see only exists in 1.3 beta1 and will be fixed in 1.3 beta2 with Bug 719193.

Comment 8

5 years ago
This works for me in Lightning 1.6.
(Reporter)

Comment 9

5 years ago
Problem gone in 1.6-1.fc17.x86_64 (probably already in earlier versions)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.