ASCII characters show at line breaks during selection

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
18 years ago
18 years ago

People

(Reporter: mik, Assigned: mjudge)

Tracking

Trunk
mozilla1.0
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [selection][correctness], URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m18) Gecko/20010104
BuildID:    2001010404



Reproducible: Always
Steps to Reproduce:
1. Open a page with enough text.
2. Press down left mouse button somewhere on the page
3. Without releasing a button move a mouse down

Actual Results:  Page scrolls down but every line covered by the selection gets some
noice at the end.

Looks like this only happens on Windows.

Comment 1

18 years ago
I tried to reproduce this (Build 2001010420 on winNT4), but I can't see any
noise when scrolling this way. Could you attach a screen shot?

Changing component to Layout.
Component: Browser-General → Layout
(Reporter)

Comment 2

18 years ago
Additional info:
This happens not on every page, but on a page with wide text (like the one
provided).
If this happens not only glitches appear, they also move.
Screenshot soon.

Comment 3

18 years ago
I am also seeing this, squares and random letters appear at the end of lines.
I've also observed this in a couple of mail messages.
Over to selection.
Assignee: asa → mjudge
Component: Layout → Selection
QA Contact: doronr → blakeross

Comment 4

18 years ago
Okay, on that w3.org page I can see it now, too. Confirming bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

18 years ago
I see this in lots of pages.  Ugly, embarrassing, should investigate for 
beta1...
Keywords: nsbeta1
Summary: select and drag to scroll adds artefacts to line ends → ASCII characters show at line breaks during selection

Comment 6

18 years ago
This bug is also visible at resource:///res/samples/test2.html, in the text 
over the gears (at the bottom).

Comment 7

18 years ago
Reproduced it in Windows98 Mozilla 0.7 (2001010901). I've narrowed it down to
the following criteria:
The more text in the page, the more frequent noise. Also it rarely immediately
appears after highlighting, but only after a few pages of it (up or down).
Sometime's there (appears) not to be a character, just blue highlight at the end
of a line
Even in pages with plain text it does this, so it doesn't have anything to do
with HTML or tables (I guess)
After scrolling up and down (with scroll bar) the bug disappears (possibly the
bug is only in select drawing function?)
They're not random characters, always the same ones (atleast in one session,
might be dependent on whatever's in memory there)

After playing with for awhile I'm pretty sure it has something to do with it
scrolling too fast and it's grabbing bits and pieces of whatever text was
already there. But that's just a hunch...

Comment 8

18 years ago
setting to moz0.9 and reassign to anthonyd
Assignee: mjudge → anthonyd
Priority: -- → P3
Target Milestone: --- → mozilla0.9

Comment 9

18 years ago
*** Bug 67315 has been marked as a duplicate of this bug. ***

Comment 10

18 years ago
nsbeta1-, adding correctness, moving to mozilla1.0
Keywords: correctness
Whiteboard: [nsbeta1-]
Target Milestone: mozilla0.9 → mozilla1.0

Comment 11

18 years ago
yeah, this bug is real stumper. difficult to repro, but not impossible and 
really wierd.
Group: netscapeconfidential?
Status: NEW → ASSIGNED
Whiteboard: [nsbeta1-] → [selection][correctness]

Updated

18 years ago
Group: netscapeconfidential?

Comment 12

18 years ago
selection
-->mjudge
Assignee: anthonyd → mjudge
Status: ASSIGNED → NEW

Updated

18 years ago
Blocks: 104166
(Reporter)

Comment 13

18 years ago
Since I can't reproduce it in 2001102903 marking this as WFM.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.