Closed Bug 644011 Opened 9 years ago Closed 9 years ago

Bump Gecko Milestone [milestone.txt] to 2.2a1pre on mozilla-central now that Firefox 4 is released.

Categories

(Release Engineering :: General, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Callek, Assigned: christian)

References

Details

Attachments

(1 file, 2 obsolete files)

We should bump the milestone.txt on mozilla-central asap.

We already have at least one project branch merged in (build-system) and in order for other applications (like SeaMonkey/Thunderbird to be able to differentiate the two) we need this bumped.

The value should be 2.2a1pre for now, as Fennec took 2.1*.

LegNeato was ok with this and said he would handle landing the bump.
John suggested the version number on dev-planning and we are going with it to keep our options open in the future if we need to change it again (as well as keep options open wrt fennec / releases/mozilla-2.1...
Attached patch Bump version (obsolete) — Splinter Review
Attachment #521084 - Flags: review?
It pains me to get review on this but there may be some gremlins lurking I am not aware of...
Comment on attachment 521084 [details] [diff] [review]
Bump version

You need to change js/src/config/milestone.txt and browser/config/version.txt too.
Attachment #521084 - Flags: review? → review-
See, that's what reviews are for ;-)
Attached patch This time with feeling (obsolete) — Splinter Review
Attachment #521084 - Attachment is obsolete: true
Attachment #521087 - Flags: review?(khuey)
Comment on attachment 521087 [details] [diff] [review]
This time with feeling

I suppose my r+ is as good as anyone's here ;-)
Attachment #521087 - Flags: review?(khuey) → review+
Comment on attachment 521087 [details] [diff] [review]
This time with feeling

Asking Callek to take a look too to make sure it's everything he needs.
Attachment #521087 - Flags: review?(bugspam.Callek)
Comment on attachment 521087 [details] [diff] [review]
This time with feeling

Callek said this is good over IRC.
Attachment #521087 - Flags: review?(bugspam.Callek) → review+
FWIW I'll add this version to amo too.
per discussion with joduinn attaching patch for JUST milestone.txt
Attachment #521087 - Attachment is obsolete: true
Comment on attachment 521111 [details] [diff] [review]
milestone bump only.

Again, this is total rubberstamping, but if this is the plan for the moment lets roll with it.
Attachment #521111 - Flags: review+
Bah, this feels like a cop-out. a=LegNeato. Callek, you landing or need me to?
To summarize from irc w/callek:

0) SeaMonkey buildbots are setup to build from mozilla-central and also releases/mozilla-2.0 (including nightlies). SeaMonkey (comm-central) automation uses the value in milestone.txt to determine which mozilla-* repo we have fetched.

1) SeaMonkey needs this change urgently to 
* unbreak SeaMonkey builds as result of build-system landing into m-c this evening, which caused a much wider divergence between m-c and m-2.0.
* to unblock work on a SeaMonkey release

2) Backing out the build-system change was one possible solution, and would likely also fix Thunderbird burning. However, backing these build-system changes out is harder work, so we dropped that idea.

3) Changing the two milestone.txt files to anything *except* 2.0 will suffice for SeaMonkey, because they'll think m-c is m-c and keep tracking mozilla-2.0 as 2.0. Specifically, Callek does not need version.txt changed. 

4)  Historically, SeaMonkey had more time to do this in the leadup to a  Firefox release, because Mozilla would branch earlier. However, this  specific Firefox4.0 release branched very late, just at RC, so SeaMonkey had little notice. 

5) Firefox is still figuring out where/how nightly users should be shared across the various existing moz-2.0/moz-2.1/m-c branches. We can change the two milestone.txt files without restricting our options. However, increasing the app version will limit choices later, so until a final decision is made, we decided to not change app version at this time. 


We note that some more observant users might be confused by a Firefox < 4.0final but a Gecko newer >4.0final, and there is the slight chance of some web-devs doing UA sniffing who might see that. However, as this is only short term, and it unblocks SeaMonkey and Thunderbird, it seems worth the tradeoff.


Thanks to Callek for taking the time to work through the details with me (I'm slow, tired after a long busy day), and for posting+landing new patch which only changes the two milestone.txt files.
(In reply to comment #14)
> Bah, this feels like a cop-out. a=LegNeato. Callek, you landing or need me to?

Actually did before I noticed your comment here, used a=joduinn

http://hg.mozilla.org/mozilla-central/rev/774ec081a9c1

Resolving since I explicitly scoped this bug not to need including Firefox version.txt
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
dupe ? bug 636190
No, not a dupe, we only bumped the Gecko milestone here, that bug is also for Firefox itself. And we may want a higher Gecko milestone bump there than 2.2a1pre
Duplicate of this bug: bump-to-2.1
Blocks: 566679
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.