Closed Bug 569966 (bump-to-2.1) Opened 10 years ago Closed 9 years ago

bump mozilla-central version to 2.1a1pre/4.1a1pre

Categories

(Release Engineering :: General, defect, P3)

x86
Windows 7
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 644011

People

(Reporter: tymerkaev, Unassigned)

References

Details

Attachments

(1 obsolete file)

User-Agent:       Firefox
Build Identifier: 

This includes both the product repository version files, the
mozilla2/config.py and talos-pool/config.py files in buildbot-configs, and the mozilla-central nagios monitoring files.

Reproducible: Always
This will get done at the time of branching. Lukas will probably be doing it.
Assignee: nobody → lsblakk
Status: UNCONFIRMED → NEW
Ever confirmed: true
Alias: (m-c|1.9.4)
Alias: (m-c|1.9.4) → m-c|1.9.4
Just to note, this might end up being 2.1a1pre/4.1a1pre - waiting on a decision from the discussion here: http://groups.google.com/group/mozilla.dev.platform/browse_thread/thread/e0da78450d4effbc?pli=1
Alias: m-c|1.9.4 → bump-to-1.9.4
Alias: bump-to-1.9.4 → bump-to-2.1
Summary: bump mozilla-central version to 1.9.4a1pre/4.1a1pre → bump mozilla-central version to 2.1a1pre/4.1a1pre
beltzner, I'd appreciate your thoughts on what our nightly users on mozilla-central builds should be updated to once we branch.  Last time there were people who wanted most users on the branch, while others wanted them on m-c to test baking patches.
We're not using a branch yet, so m-c should bump to 2.0b1pre/4.0b1pre if it happens before we tag for beta1, or 2.0b2pre/4.0b2pre if it happens afterwards.
I'm talking about this scenario, please fix up any misconceptions:

* Firefox 4.0b1 will come from mozilla-central, and at some point we point we will bump m-c to 4.0b1pre/2.0b1pre. RelEng to ensure 3.7* users continue to get nightly updates to 4.0b1pre

* 4.0b1 build1 will freeze and be tagged, we'll bump m-c to 4.0b2pre/2.0b2

* at some point later electrolysis will land and we'll start using the mozilla-2.0 branch. m-c will be bumped to 4.1a1pre/2.1a1pre

At this point we have a choice where we direct nightly users with versions 3.7* and 4.0*. We can either
* move them to the mozilla-2.0 branch, and expect a fair chunk of users will switch back to m-c themselves by manual install
* keep them on mozilla-central by directing to 4.1a1pre for a few days, then start up 4.0 -> 4.0 nightly updates and keep anyone who hasn't already updated to 4.1a1pre

AFAIK we can't offer them a choice other than the firstrun page pointing to installers of the other branch.
Attached patch patch (obsolete) — Splinter Review
Attachment #456261 - Attachment is obsolete: true
Blocks: 617539
putting this back in the pool since it's not something I'm actively working on and there's no ETA for this to go live.
Assignee: lsblakk → nobody
Poor little bug, you waited and waited and waited and waited, and when your time came after waiting 9 months to give birth to 2.1, someone else got to give birth to 2.2 instead :(
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 644011
No longer blocks: 566679
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.