Autocompletion leaves first 'h' of suggested autocompletion with existing tab

RESOLVED DUPLICATE of bug 559878

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 559878
7 years ago
7 years ago

People

(Reporter: Frank Maas, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

If, after typing one charachter, the location bar suggests an autocompletion with an existing tab, it does so with all but the first charachter (the 'h' of http) of the url selected. Typing the 2nd character will make the selected part disappear, with the 'h' remaining and the originally typed character gone.

Reproducible: Always

Steps to Reproduce:
0. We should have a tab open to the Bugzilla site (https://bugzilla.mozilla.org, please note that this is merely an example, the bug has no correlation to httpS sites).
1. Let's say we want to visit http://m.somesite.com (please note that this again is merely an example, the bug has no correlation to using mobile sites), so we type the 'm'
2) The location bar shows 'Change to tab|https://bugzilla.mozilla.org...' as it likes to autocomplete to an existing tab and the url of this tab contains an 'm'. 
3) Of that suggested link the 'h' is not selected (ie. inverse text), the remaining part of the url is selected
3) Now we type '.'
4) 'Change to tab' disappears, as does the selected part of the suggested URL. The 'h' remains and the '.' is appended. So instead of 'm.' (what we typed) we now have 'h.'.

As a side effect of this the real completion does not work either. Because when we'd like to type 'mozilla to select a tab or bookmark with that word in it, we get 'hozilla' (which is not found).
Actual Results:  
see steps to reproduce

Expected Results:  
what has been typed should always be kept and used as soon as autocompletion fails

Should have tested this first with all plugins disabled. Thought of this after entering all info above... Will do so now and get back.
(Reporter)

Comment 1

7 years ago
Checked without addons: bug remains.

Did another search through the bugs and found an old one that describes this, so marking it as duplicate
(Reporter)

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 559878
You need to log in before you can comment on or make changes to this bug.