Closed Bug 644175 Opened 13 years ago Closed 3 years ago

Safe Mode Shift Key Modifier Conflicts With Built-In Windows 7 Keyboard Shortcuts

Categories

(Firefox :: General, defect)

4.0 Branch
x86_64
Windows 7
defect
Not set
major

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: cspaul, Unassigned)

References

(Blocks 1 open bug)

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

Holding the shift key while launching Firefox 4 starts it in safe mode, but this conflicts with built-in Windows 7 shortcuts.

The shortcut key in Windows 7 to launch applications pinned to the taskbar is windows key + shift + [1-9]. Trying to use these shortcut keys to launch Firefox starts it in safe mode on a computer that loads the browser quickly, or for slow typists who don't release the shift key fast enough.

Reproducible: Always

Steps to Reproduce:
1. Start FF4 in Windows 7.
2. Right click the icon on the taskbar and select "Pin This Program to the Taskbar".
3. Close FF4.
4. Restart Firefox by using the keyboard shorcut Windows Key + Shift + [# representing icon position on the taskbar]
Actual Results:  
Firefox launches in safe mode.

Expected Results:  
Firefox launches outside of safe mode.
Hmm, didn't we switch from using shift? Looks like we have another conflict.
No, it is still the shift key. I had hoped it got in early enough that any conflicts would be worked out by the beta audience. Since this is the same key used to launch some MS Office apps with macros / script disabled I suspect they are affected as well.

This can probably be fixed by checking if the Windows key is held down like the current checks for ctrl and alt
No. If you input uppercase character when executing Firefox, Firefox is starting with safe mode.

There was only one solution. Remove this function.
Version: unspecified → 4.0 Branch
Please remove this function. In a corporate environment, Firefox is usually locked down using add-ons. Pressing the shift key to start safe mode makes it way too easy to disable these add-ons. At the very least the use of keyboard modifier should be configurable, with an option to disable it.
This issue is similar to bug 619866 where the issue was that cltr+shift+key triggered Safe Mode.
Bug 653410 asks to provide a way to disable safe mode altogether. I suppose this is a different issue than being able to configure the key modifier.
Blocks: safe-mode

Marking this as Resolved > Worksforme since the issue is no longer reproducible on the latest versions of Firefox Nightly 96.0a1 (2021-11-23), beta 95.0b10 or release 94.0.2 on Windows 10 and Windows 7.
If anyone is still able to reproduce this issue either re-open this ticket or file a new one.

Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.