Closed Bug 644297 Opened 9 years ago Closed 9 years ago

_MD5*/_SHA* symbols not found during Shark universal build

Categories

(Firefox Build System :: General, defect)

All
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: glandium, Assigned: glandium)

Details

Attachments

(1 file, 1 obsolete file)

/tools/buildbot/bin/python2.6 /builds/slave/try-osx64/build/config/buildlist.py ../../dist/bin/chrome.manifest "manifest components/nsDefaultCLH.manifest"
/tools/buildbot/bin/python2.6 /builds/slave/try-osx64/build/config/pythonpath.py -I../../../config /builds/slave/try-osx64/build/config/expandlibs_exec.py --uselist --  g++-4.2 -arch i386 -o crashreporter  -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -gdwarf-2 -isysroot /Developer/SDKs/MacOSX10.5.sdk -fno-strict-aliasing -fpascal-strings -fno-common -fshort-wchar -pthread -DNO_X11  -DNDEBUG -DTRIMMED -gdwarf-2 -O3 -fno-omit-frame-pointer  crashreporter.o crashreporter_unix_common.o crashreporter_osx.o   -framework Cocoa -lobjc  -framework ExceptionHandling -Wl,-executable_path,/builds/slave/try-osx64/build/obj-firefox/i386/dist/bin  -L../../../dist/bin -L../../../dist/lib ../../../toolkit/crashreporter/google-breakpad/src/common/mac/libbreakpad_mac_common_s.a   -framework Cocoa    
Undefined symbols:
  "_MD5Init", referenced from:
      google_breakpad::FileID::FileIdentifier(unsigned char*)in file_id.o
      MacFileUtilities::MachoID::MD5(int, unsigned char*)in macho_id.o
  "_SHA_Final", referenced from:
      MacFileUtilities::MachoID::SHA1(int, unsigned char*)in macho_id.o
  "_MD5Update", referenced from:
      google_breakpad::FileID::FileIdentifier(unsigned char*)in file_id.o
      MacFileUtilities::MachoID::UpdateMD5(unsigned char*, unsigned long)in macho_id.o
  "_MD5Final", referenced from:
      google_breakpad::FileID::FileIdentifier(unsigned char*)in file_id.o
      MacFileUtilities::MachoID::MD5(int, unsigned char*)in macho_id.o
  "_SHA_Init", referenced from:
      MacFileUtilities::MachoID::SHA1(int, unsigned char*)in macho_id.o
  "_SHA_Update", referenced from:
      MacFileUtilities::MachoID::UpdateSHA1(unsigned char*, unsigned long)in macho_id.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
make[7]: *** [crashreporter] Error 1
Attached patch workaround (obsolete) — Splinter Review
I'm going to try this on try. Removing the ifdef entirely works, but presumably this should be enough.

This would allow to get shark building properly until we actually find out what's going on.
Assignee: nobody → mh+mozilla
Fails with:
Undefined symbols:
  "_MD5Init", referenced from:
      google_breakpad::FileID::FileIdentifier(unsigned char*)in file_id.o
      MacFileUtilities::MachoID::MD5(int, unsigned char*)in macho_id.o
  "_MD5Update", referenced from:
      google_breakpad::FileID::FileIdentifier(unsigned char*)in file_id.o
      MacFileUtilities::MachoID::UpdateMD5(unsigned char*, unsigned long)in macho_id.o
  "_MD5Final", referenced from:
      google_breakpad::FileID::FileIdentifier(unsigned char*)in file_id.o
      MacFileUtilities::MachoID::MD5(int, unsigned char*)in macho_id.o
ld: symbol(s) not found
Attached patch workaroundSplinter Review
So in the end, this is what works.
Attachment #521283 - Attachment is obsolete: true
Attachment #521303 - Flags: review?(ted.mielczarek)
Comment on attachment 521303 [details] [diff] [review]
workaround

I would really like to sort out the root cause here. :-/
Attachment #521303 - Flags: review?(ted.mielczarek) → review+
http://hg.mozilla.org/mozilla-central/rev/d60d8c1c1f8a
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
I backed this out because it was part of a push that caused bug 644790, and out of an abundance of caution (and a desire to get bug 644790 working again before we get to sleep), I backed the whole push out.  (It was two tiny patches, of which this was one, and then the likely culprit in a series of five patches that may have had to be backed out all together.)

http://hg.mozilla.org/mozilla-central/rev/2ec2475ef8dd

(I'm already thinking maybe backing these two out was a mistake, but...)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
http://hg.mozilla.org/mozilla-central/rev/5100b8349ba9
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.