Closed Bug 645152 Opened 9 years ago Closed 9 years ago

Deactivate this device warning is confusing and too dramatic

Categories

(Firefox :: Sync, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla8

People

(Reporter: philikon, Assigned: philikon)

References

Details

(Keywords: ux-tone, Whiteboard: [verified in services])

Attachments

(2 files)

No description provided.
This bug brought to you by multiple questions on SUMO and Reddit.
Eventually, we might want to actually do what the dialog box says (and wipe out all of your data when you deactivate, especially if you are deactivating becuase you are giving the computer away).  In the meantime we might want to rephrase this to:

"This computer will no longer be associated with your sync account, however all of your data (like bookmarks, passwords, and preferences) will remain intact."
(In reply to comment #2)
> "This computer will no longer be associated with your sync account, however all
> of your data (like bookmarks, passwords, and preferences) will remain intact."

Two points of feedback.

First, "computer" should be "device", since they clicked a link titled "Deactivate this device".

Second, some users were confused as to whether Deactivate would clear their sync data from the server.  The above text does not clearly indicate "your sync data will remain intact on the server".
Ok, how about:

"This device will no longer be associated with your sync account, however all of your personal data (both on this computer and stored in your sync account) will remain intact."
I like it.  Replace computer with device, though.
Another quick thought, we should change the term to "un-link" instead of deactivate, since that captures what the action currently is a bit better.  Also we'll later support remote wipes, and in those cases the devices really will be deactivated (unlinked, data removed, etc.)
Duplicate of this bug: 669209
Summary: Deactive this device warning is confusing and too dramatic → Deactivate this device warning is confusing and too dramatic
+1 to Alex proposal.

Even myself that I'm constantly adding and removing devices feel scared of loosing data in the process. 

As next step, perhaps, is more intuitive to link to the account portal and have a list of synced devices that you can activate and deactivate as you please. The usecase is clear on mobile devices: I want to lend a device to a colleague. I want to deactivate Sync but I plan to activate it in some hours or days. So I un-tick it on the Account Portal and tick it again. Also this way you really understand what is happening.
Attached patch v1Splinter Review
Combined suggestions from comment 4 through 6. Slightly tweaked the text to be a bit shorter.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #544506 - Flags: review?(rnewman)
Attached image screenshot
Note the "Unlink This Device" link in the pref pane and the new text in the dialog box.
Whiteboard: [ux-wanted]
Attachment #544506 - Flags: review?(rnewman) → review+
Whiteboard: [fixed in services] → [verified in services]
http://hg.mozilla.org/mozilla-central/rev/3a77968d5074
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla8
Status: RESOLVED → VERIFIED
Component: Firefox Sync: UI → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.