Closed Bug 645359 Opened 9 years ago Closed 9 years ago

crash [@ mozilla::dom::PContentParent::SendScreenSizeChanged]

Categories

(Firefox for Android Graveyard :: General, defect, critical)

ARM
Android
defect
Not set
critical

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: kbrosnan, Assigned: jdm)

References

Details

(Keywords: crash)

Crash Data

Attachments

(1 file, 1 obsolete file)

This bug was filed from the Socorro interface and is 
report bp-f61d8bae-6459-43ba-9294-44bf52110326 .
============================================================= 

Crash on startup. Possibly releated to mfinkle's bug 645347 but I get the crash reporter every time.
Frame 	Module 	Signature [Expand] 	Source
0 	libxul.so 	mozilla::dom::PContentParent::SendScreenSizeChanged 	PContentParent.cpp:621
1 	libxul.so 	ContentCreationNotifier::Observe 	widget/src/android/nsWindow.cpp:103
2 	libxul.so 	nsObserverList::NotifyObservers 	nsVoidArray.h:63
3 	libxul.so 	nsObserverService::NotifyObservers 	nsTHashtable.h:170
4 	libxul.so 	mozilla::dom::ContentParent::Init 	nsCOMPtr.h:492
5 	libxul.so 	mozilla::dom::ContentParent::ContentParent 	nsCOMPtr.h:492
6 	libxul.so 	mozilla::dom::ContentParent::GetSingleton 	dom/ipc/ContentParent.cpp:162
7 	libxul.so 	nsFrameLoader::TryRemoteBrowser 	content/base/src/nsFrameLoader.cpp:1782
8 	libxul.so 	nsFrameLoader::ShowRemoteFrame 	content/base/src/nsFrameLoader.cpp:892
9 	libxul.so 	nsFrameLoader::Show 	content/base/src/nsFrameLoader.cpp:808
10 	libxul.so 	nsSubDocumentFrame::ShowViewer 	layout/generic/nsIFrame.h:2925
11 	libxul.so 	AsyncFrameInit::Run 	layout/generic/nsSubDocumentFrame.cpp:155
12 	libxul.so 	nsContentUtils::RemoveScriptBlocker 	nsCOMPtr.h:492
13 	libxul.so 	nsDocument::EndUpdate 	content/base/src/nsDocument.cpp:4030
14 	libxul.so 	nsXULDocument::EndUpdate 	content/xul/document/src/nsXULDocument.cpp:3334
15 	libxul.so 	nsINode::ReplaceOrInsertBefore 	nsCOMPtr.h:492
16 	libxul.so 	nsINode::InsertBefore 	nsINode.h:1224
17 	libxul.so 	nsIDOMNode_InsertBefore 	dom_quickstubs.cpp:6067
18 	libxul.so 	js::Interpret 	js/src/jsinterp.cpp:4801
19 	libxul.so 	js::Invoke 	js/src/jsinterp.cpp:653
20 	libxul.so 	js::ExternalInvoke 	js/src/jsinterp.cpp:863
21 	libxul.so 	JS_CallFunctionValue 	js/src/jsapi.cpp:5173
22 	libxul.so 	nsXPCWrappedJSClass::CallMethod 	js/src/xpconnect/src/xpcwrappedjsclass.cpp:1674
23 	libxul.so 	nsXPCWrappedJS::CallMethod 	js/src/xpconnect/src/xpcwrappedjs.cpp:589
24 	libxul.so 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/unix/xptcstubs_arm.cpp:132
25 	libxul.so 	libxul.so@0x93b5bc 	
26 	libxul.so 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/unix/xptcinvoke_arm.cpp:199
27 	libxul.so 	nsScriptSecurityManager::CanAccess 	caps/src/nsScriptSecurityManager.cpp:3220
28 	libxul.so 	XPCWrappedNative::CallMethod 	js/src/xpconnect/src/xpcwrappednative.cpp:3136
29 	libxul.so 	XPC_WN_CallMethod 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1613
30 	libxul.so 	js::Interpret 	js/src/jsinterp.cpp:4801
31 	libxul.so 	js::Invoke 	js/src/jsinterp.cpp:653
32 	libxul.so 	js::ExternalInvoke 	js/src/jsinterp.cpp:863
33 	libxul.so 	JS_CallFunctionValue 	js/src/jsapi.cpp:5173
34 	libxul.so 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:1915
35 	libxul.so 	nsJSEventListener::HandleEvent 	dom/src/events/nsJSEventListener.cpp:230
36 	libxul.so 	nsEventListenerManager::HandleEventSubType 	content/events/src/nsEventListenerManager.cpp:1136
37 	libxul.so 	nsEventListenerManager::HandleEventInternal 	content/events/src/nsEventListenerManager.cpp:1231
38 	libxul.so 	nsEventTargetChainItem::HandleEvent 	content/events/src/nsEventListenerManager.h:146
39 	libxul.so 	nsEventTargetChainItem::HandleEventTargetChain 	content/events/src/nsEventDispatcher.cpp:344
40 	libxul.so 	nsEventDispatcher::Dispatch 	content/events/src/nsEventDispatcher.cpp:648
41 	libxul.so 	DocumentViewerImpl::LoadComplete 	layout/base/nsDocumentViewer.cpp:1075
42 	libxul.so 	nsDocShell::EndPageLoad 	docshell/base/nsDocShell.cpp:6092
43 	libxul.so 	nsDocShell::OnStateChange 	nsCOMPtr.h:492
44 	libxul.so 	nsDocLoader::FireOnStateChange 	uriloader/base/nsDocLoader.cpp:1318
45 	libxul.so 	nsDocLoader::doStopDocumentLoad 	uriloader/base/nsDocLoader.cpp:953
46 	libxul.so 	nsDocLoader::DocLoaderIsEmpty 	uriloader/base/nsDocLoader.cpp:820
47 	libxul.so 	nsDocLoader::OnStopRequest 	uriloader/base/nsDocLoader.cpp:706
48 	libxul.so 	nsLoadGroup::RemoveRequest 	netwerk/base/src/nsLoadGroup.cpp:680
49 	libxul.so 	imgRequestProxy::RemoveFromLoadGroup 	modules/libpr0n/src/imgRequestProxy.cpp:231
50 	libxul.so 	imgRequestProxy::OnStopRequest 	modules/libpr0n/src/imgRequestProxy.cpp:729
51 	libxul.so 	imgStatusTracker::SendStopRequest 	modules/libpr0n/src/imgStatusTracker.cpp:524
52 	libxul.so 	imgRequest::OnStopRequest 	nsTObserverArray.h:304
53 	libxul.so 	ProxyListener::OnStopRequest 	modules/libpr0n/src/imgLoader.cpp:2009
54 	libxul.so 	nsJARChannel::OnStopRequest 	nsCOMPtr.h:663
55 	libxul.so 	nsInputStreamPump::OnStateStop 	nsCOMPtr.h:663
56 	libxul.so 	nsInputStreamPump::OnInputStreamReady 	netwerk/base/src/nsInputStreamPump.cpp:403
57 	libxul.so 	nsInputStreamReadyEvent::Run 	nsCOMPtr.h:663
58 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:633
59 	libxul.so 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/unix/xptcinvoke_arm.cpp:199
60 	libxul.so 	XPCWrappedNative::CallMethod 	js/src/xpconnect/src/xpcwrappednative.cpp:3136
61 	libxul.so 	XPC_WN_CallMethod 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1613
62 	libxul.so 	js::Interpret 	js/src/jsinterp.cpp:4801
63 	libxul.so 	js::Invoke 	js/src/jsinterp.cpp:653
64 	libxul.so 	js::ExternalInvoke 	js/src/jsinterp.cpp:863
65 	libxul.so 	JS_CallFunctionValue 	js/src/jsapi.cpp:5173
66 	libxul.so 	nsXPCWrappedJSClass::CallMethod 	js/src/xpconnect/src/xpcwrappedjsclass.cpp:1674
67 	libxul.so 	nsXPCWrappedJS::CallMethod 	js/src/xpconnect/src/xpcwrappedjs.cpp:589
68 	libxul.so 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/unix/xptcstubs_arm.cpp:134
69 	libxul.so 	libxul.so@0x93b5bc 	
70 	libxul.so 	EnumRun 	toolkit/components/commandlines/nsCommandLine.cpp:655
Depends on: 621453
Attachment #522127 - Attachment is obsolete: true
Comment on attachment 522138 [details] [diff] [review]
Need to call Init after there's a global ContentParent available for use in observers.

Benjamin, I already pushed this because it fixes the startup crash on fennec.  I'll fix any problems you note ASAP.
Attachment #522138 - Flags: review?(benjamin)
Duplicate of this bug: 645347
Just to verify, the pushed patch fixes the crash for me.
Attachment #522138 - Flags: review?(benjamin) → review+
Mark and Josh, although the fix is already landed to m-c, why does this keep open?

http://hg.mozilla.org/mozilla-central/rev/fbe53bc0d7f6
Assignee: nobody → josh
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
I'll mark it as verified fixed.
Status: RESOLVED → VERIFIED
Crash Signature: [@ mozilla::dom::PContentParent::SendScreenSizeChanged]
You need to log in before you can comment on or make changes to this bug.