Last Comment Bug 645494 - Tab bar background gradient is not smooth
: Tab bar background gradient is not smooth
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: All Mac OS X
: -- normal (vote)
: Firefox 8
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 667476
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-27 07:31 PDT by jacek
Modified: 2011-08-12 12:22 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Gradient problem with Finder comparison (39.50 KB, image/png)
2011-03-27 07:32 PDT, jacek
no flags Details
Title bar inconsistent with URL bar (19.76 KB, image/png)
2011-03-27 07:33 PDT, jacek
no flags Details
No graying-out of titles while in lost focus (76.13 KB, image/png)
2011-03-27 07:34 PDT, jacek
no flags Details

Description jacek 2011-03-27 07:31:33 PDT
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0) Gecko/20100101 Firefox/4.0

1. Tab-bar-background gradient flaw: when in tabs-on-top mode, it is clearly seen, that gradient is not smooth. It looks like a bad-quality image was used as a background and gradient stripes are visible.
2. While no tab is displayed (single page view), the title bar is not consistent with the URL bar.
3. In lost-focus, the tabs titles and bookmarks don't get grayed out like they should.

Reproducible: Always

Steps to Reproduce:
Happens always.
Actual Results:  
The theme flaws are visible.

Expected Results:  
1. Tab-bar background should have clear, smooth gradient.
2. Titlebar should be consistent with URL bar while in no tab mode.
3. Titles should be grayed out a bit.
Comment 1 jacek 2011-03-27 07:32:56 PDT
Created attachment 522209 [details]
Gradient problem with Finder comparison
Comment 2 jacek 2011-03-27 07:33:50 PDT
Created attachment 522210 [details]
Title bar inconsistent with URL bar
Comment 3 jacek 2011-03-27 07:34:40 PDT
Created attachment 522211 [details]
No graying-out of titles while in lost focus
Comment 4 jacek 2011-03-27 07:36:47 PDT
The gradient problem is also visible in the not-selected tab background (under the tab title).
Comment 5 Markus Stange [:mstange] 2011-03-27 09:23:45 PDT
> 1. Tab-bar background should have clear, smooth gradient.

Let's make this bug only about this.

> 2. Titlebar should be consistent with URL bar while in no tab mode.

That's bug 618770.

> 3. Titles should be grayed out a bit.

Not graying them out is intentional. It's meant to convey that clicking them on a background window won't just focus the window but will also activate the button / tab.
Comment 6 Vlad [QA] 2011-04-08 07:17:09 PDT
Works for me on Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.2a1pre) Gecko/20110407 Firefox/4.2a1pre

Also, could you see if the issue occurs if using Firefox in safe mode:
http://support.mozilla.com/kb/Safe+Mode

How about with a new, empty testing profile? (Don't install any addons into it)
http://support.mozilla.com/kb/Basic+Troubleshooting#w_8-make-a-new-profile
Comment 7 jacek 2011-04-09 11:30:01 PDT
Well, it doesn't depend on a profile - Firefox seems to use an image as background, and not a native Mac OS X GUI element. And this image is low quality. I tested it even on 10.7 preview version - Firefox does not incorporate new Lion interface. And still, it has gradient problems. Please provide screenshot to prove that it works for you. Or maybe it has been already fixed for your version - 4.2a1pre. I am using 4.0.
Comment 8 Markus Stange [:mstange] 2011-04-13 04:02:43 PDT
It's not fixed yet.
Vlad, whether you see this depends on many parameters, including eyesight quality, lightning conditions, monitor contrast levels, monitor angle, etc.
Comment 9 Vlad [QA] 2011-04-21 07:18:17 PDT
Reporter, do you have anything new to add about this issue?
Comment 10 jacek 2011-04-21 07:21:38 PDT
No.
Comment 11 Markus Stange [:mstange] 2011-08-03 03:48:24 PDT
Bug 667476 will fix this (even on 10.5 / 10.6).
Comment 12 d 2011-08-12 12:05:47 PDT
Can this be resolved now?
Comment 13 Markus Stange [:mstange] 2011-08-12 12:22:20 PDT
Yup.

Note You need to log in before you can comment on or make changes to this bug.