Closed Bug 645756 Opened 9 years ago Closed 7 months ago

Zooming disabled, panning and rendering problems on pages with frameset / frames

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: kbrosnan, Unassigned)

References

()

Details

(Keywords: helpwanted, mobile, Whiteboard: [band-aid patch checked in for Fx9])

Attachments

(1 file)

From the support forums - https://support.mozilla.com/en-US/questions/795105

It is an internal site but the user posted to me the contents of a problematic page.

Pinch to zoom does not work on the site in listed in the URL. There is also some oddness with panning. There are scrollbars when there should not be any.
Many pages with frames seem to be affected.

On Galaxy Tab, the test case loads with zooming disabled, incorrect resolution,
and the right-hand frame cut off.  Switching to landscape orientation, the page
does not fill the screen (surrounded by checkerboards).

To reproduce the bug on my T-Mobile G2, I had to change orientation from
portrait to landscape and back.
tracking-fennec: --- → ?
OS: Windows 7 → All
Hardware: x86 → All
Summary: Zooming does not work on this site → Zooming disabled, panning and rendering problems on pages with frameset / frames
To reproduce the zooming problem on my Nexus S (Gingerbread 2.3.3) with Firefox 4.0 RC 1 build 3, I simply opened http://www.integrale in portrait mode. I have to horizontal scroll the frame on the right to read it.
On http://fprak.phy.tu-dresden.de/F_Prak/ , the frame is cut off on the right, not all text is visible.
Oh, and clicking the "Gruppen" link shows a page which can be scrolled/panned, "Versuche" is partly scrollable, but cut off at the bottom.
Assignee: nobody → ben
Whiteboard: [fennec-4.1?]
tracking-fennec: ? → 2.0-
This is really painful, since SquirrelMail and Horde are affected too. Considering Android's own browser is unable to display correctly websites with frames :/
Duplicate of this bug: 652370
tracking-fennec: - → 7+
Whiteboard: [fennec-4.1?]
Duplicate of this bug: 671191
Kevin, can you still reproduce this?
tracking-fennec: 7+ → ?
Yes, this can still be reproduced.

I've seen it on http://www.browserscope.org/jskb/test and http://www.handleidinghtml.nl/
The text can look blurry, which seems to be zoom related.

I also noticed that trying to pinch-to-zoom very much on one of the pages, it causes Fennec to hang, causing a reboot of Android. I'm using the LG Optimus Black.
tracking-fennec: ? → +
I also still suffer from it on SquirrelMail at least (HTC Desire Z).
Blocks: 680716
This patch disables zooming for frameset pages, since zooming in those pages makes things only worse (hiding parts of content/blurry text/unable to tap on links).
It's not a good solution of course, but it would at least improve things for now, until the ideal solution comes by.
Blocks: 676910
Comment on attachment 555095 [details] [diff] [review]
disable zooming for frameset pages

Review of attachment 555095 [details] [diff] [review]:
-----------------------------------------------------------------

Matt, what do you think about this as a stopgap for now?
Attachment #555095 - Flags: review?(mbrubeck)
Attachment #555095 - Flags: review?(mbrubeck) → review+
Duplicate of this bug: 681113
The patch won't fix this bug, so don't mark it fixed after it has been checked in (and thanks for checking in).
Keywords: checkin-needed
http://hg.mozilla.org/integration/mozilla-inbound/rev/0ed0529fa6cf
Status: NEW → ASSIGNED
Keywords: checkin-needed
Target Milestone: --- → Firefox 9
Assignee: ben → martijn.martijn
Whiteboard: [landed in inbound, but don't close]
Assignee: martijn.martijn → ben
http://hg.mozilla.org/mozilla-central/rev/0ed0529fa6cf
Whiteboard: [landed in inbound, but don't close] → [band-aid patch checked in for Fx9]
Target Milestone: Firefox 9 → ---
Attachment #555095 - Flags: checkin+
Assignee: ben → doug.turner
Duplicate of this bug: 691068
Assignee: doug.turner → nobody
tracking-fennec: + → -
No assignee, updating the status.
Status: ASSIGNED → NEW
tracking-fennec: - → ---
No assignee, updating the status.
Closing all opened bug in a graveyard component
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.