navigate back/forward is completely broken

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: alice0775, Assigned: smaug)

Tracking

({regression})

Trunk
x86
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
Build Identifier:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.2a1pre) Gecko/20110328
Firefox/4.2a1pre ID:20110328125522

To navigate back one page, It is necessary to click two times of back buttons.
This is very annoying.

This does not happen on Firefox3.6.x and Google Chrome 12.0.717.0 canary build.

Steps to Reproduce:
1. Start Minefield with new profile
2. Open URL ( http://sankei.jp.msn.com/sports/sports.htm )
3. Click a link of list
4. Click Back button(navigation back)
   --- the page did not change
5. Click Back button again
   --- you can see the initial page of step2

See Screenshot

Actual Results:
  To navigate back one page, It is necessary to click two times of back buttons.

Expected Results:
  The navigation back should be carried out in one click.
(Reporter)

Comment 1

8 years ago
Regression window:
Works:
http://hg.mozilla.org/mozilla-central/rev/f43f9b764efb
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100817 Minefield/4.0b4pre ID:20100817063641
Fails:
http://hg.mozilla.org/mozilla-central/rev/353da09ea0dd
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100817 Minefield/4.0b4pre ID:20100817081027
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f43f9b764efb&tochange=353da09ea0dd
Triggered by:
353da09ea0dd	Olli Pettay — Bug 462076 - Dynamically inserted iframes on refresh sometimes trade places, r=bz
Blocks: 462076
Keywords: regression
(Reporter)

Comment 2

8 years ago
Created attachment 522663 [details]
Screenshot STR
Created attachment 528113 [details]
log

This is log with successful STR.

Search for *** This is where I pressed the backed button

Looks like about:document-onload-blocker (I have also seen about:blank there) is put in the history chain instead of the previous page.
(Reporter)

Comment 4

8 years ago
http://hg.mozilla.org/mozilla-central/rev/c5e8cc100248
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0a1) Gecko/20110426 Firefox/6.0a1 ID:20110426030544

navigate back/forward is COMPLETELY broken.

Steps to Reproduce:
1. Start Minefield with new profile
2. Open URL  http://sankei.jp.msn.com/sports/news/110426/bbl11042623360013-n1.htm  (not a permanent link)
3. Open URL https://bugzilla.mozilla.org/
4. Click Back button(navigation back)
   ---  you can see the page of step2
   --- Forward button is disabled
5. Click Forward button again
   --- I cannot go to page of stepp3

Actual Results:
  Forward button is disabled
  I cannot go to page of stepp3


Expected Results:
  Forward button should be enabled after step4.
  Should be navigated to the page of step3
Severity: normal → major
Summary: To navigate back one page, It is necessary to click two times of back buttons → navigate back/forward is completely broken
(Assignee)

Comment 5

8 years ago
Need to figure out what is happening in the case comment 4, but there are
valid cases for such behavior. If after going back the page changes something
(adds new iframes and loads something there) there can be new things
in the session history, in which case the old "forward-branch" can be removed.
(Reporter)

Comment 6

8 years ago
Umm,Firefox3.6.16 works as expected, Google Chrome12.0.747.0 canary build and IE9 work as expected too.
(Assignee)

Comment 7

8 years ago
Yeah, I'm not saying gecko behavior is right in this case.
Just that there is a valid case for such behavior, depending on the
web pages involved.

(In general I wouldn't count on webkit's session history to do
anything sane, but IE is usually good.)

I'll investigate this.
Assignee: nobody → Olli.Pettay
(Reporter)

Comment 8

7 years ago
Works for me.
This was fixed  on between Firefox7 and 8.
 
Fixed window(m-c)
Fails:
http://hg.mozilla.org/mozilla-central/rev/be4b064f1159
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110804 Firefox/8.0a1 ID:20110804030732
Fixed:
http://hg.mozilla.org/mozilla-central/rev/5d742d2e4304
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110803 Firefox/8.0a1 ID:20110804022245
Fixed pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=be4b064f1159&tochange=5d742d2e4304



Fixed window(m-i)
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/1d1c771a3aba
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110803 Firefox/8.0a1 ID:20110803015303
Fixed:
http://hg.mozilla.org/integration/mozilla-inbound/rev/144add433e72
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110803 Firefox/8.0a1 ID:20110803113010
Fixed pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=1d1c771a3aba&tochange=144add433e72

Fixed by:
Bug 673467
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Depends on: 673467
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.