OS level crash when updating Firefox kn 3.5.18->4.0 advertised

RESOLVED DUPLICATE of bug 628829

Status

()

Toolkit
Application Update
RESOLVED DUPLICATE of bug 628829
7 years ago
7 years ago

People

(Reporter: Teodosia Pop, Unassigned)

Tracking

Trunk
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
Created attachment 522679 [details]
screenshot

Build ID:  
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; mn; rv:1.9.1.18) Gecko/20110319 Firefox/3.5.18
and 
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; kn; rv:1.9.1.18) Gecko/20110319 Firefox/3.5.18

Mac 10.5.8

After the update from 3.5.18 to 4.0 is downloaded and FF is restarted, the update fails to install for kn and mn builds.

Steps to Reproduce:
1. Install 3.5.18 kn/mn FF build.
2. Set up FF for release test.
3. Restart FF and wait to be prompted for the update.
2. Download the update and restart FF.

Actual Results:
The update is downloaded, but after the restart, the update fails to install (see screenshot).

Expected Results:
The update should install without failures.
Component: General → Application Update
Product: Firefox → Toolkit
QA Contact: general → application.update
Version: 3.5 Branch → Trunk
This is reproducible with Firefox 3.5.18 kn and ml on Mac OSX 10.6.

I've got copies of my OS crash logs which I will attach momentarily.
Summary: Fail to install FF update 3.5.18->4.0 on Mac 10.5 on several locale builds → OS level crash when updating Firefox 3.5.18->4.0 advertised
Created attachment 522753 [details]
Crash Log: After update

The following is a crash log which happens immediately following the update process (ie. after clicking Restart on the update dialog)
Created attachment 522755 [details]
Crash Log: After manual restart

The following is a crash log which now happens every time I try to start Firefox with this failed update.
Attachment #522755 - Attachment mime type: text/rtf → text/plain
I get: "The application Firefox Software Update quit unexpectedly", the crash log is similar to what Anthony posted.
This is bug 628829 which hasn't made it into a release vehicle yet due to chemspills and in bug 629256 releng is supposed to have prevented updates for these locales on Mac.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Summary: OS level crash when updating Firefox 3.5.18->4.0 advertised → OS level crash when updating Firefox kn 3.5.18->4.0 advertised
Duplicate of bug: 628829
Did you change your update channel, by any chance?
(In reply to comment #6)
> Did you change your update channel, by any chance?

Update channel is releasetest.
When I have tested the updates from 3.5.18->4.0 last week I didn't got updates served on the release channel:

http://mozmill-archive.brasstacks.mozilla.com/#/update/report/b0c5cbbd24bf827d6dcfffc745d59808
Status: RESOLVED → VERIFIED
(In reply to comment #7)
> (In reply to comment #6)
> > Did you change your update channel, by any chance?
> 
> Update channel is releasetest.

Okay, if that's the case for Teodosia as well, then this is NOTABUG because we don't ship anything on that channel. Teodosia, do you know what your update channel is?
Status: VERIFIED → RESOLVED
Last Resolved: 7 years ago7 years ago
(In reply to comment #9)
> (In reply to comment #7)
> > (In reply to comment #6)
> > > Did you change your update channel, by any chance?
> > 
> > Update channel is releasetest.
> 
> Okay, if that's the case for Teodosia as well, then this is NOTABUG because we
> don't ship anything on that channel. Teodosia, do you know what your update
> channel is?

We instructed him to use releasetest -- I assume this was what he was testing on.  I'll let him comment if untrue.

Just for clarification, here is my STR:

1. Install Firefox 3.5.18 kn
2. Set update channel to releasetest
3. Set app.update.interval to 60 and app.update.timer to 600
4. Restart Firefox
5. Click notification when it appears
6. Install the update and click restart

Result: OS Level Crash
So, if he was using releasetest, then this is fine to be a dupe of 628829, but it's not a real issue, since neither of the "real" channels (beta and release) are affected.
(In reply to comment #11)
> So, if he was using releasetest, then this is fine to be a dupe of 628829, but
> it's not a real issue, since neither of the "real" channels (beta and release)
> are affected.

Ben, but what I have mentioned earlier already on rd we really should keep release and releasetest in sync.
(In reply to comment #12)
> (In reply to comment #11)
> > So, if he was using releasetest, then this is fine to be a dupe of 628829, but
> > it's not a real issue, since neither of the "real" channels (beta and release)
> > are affected.
> 
> Ben, but what I have mentioned earlier already on rd we really should keep
> release and releasetest in sync.

Yes, we should. It's been noted for the future.
I'll remove the test snippets for these broken locales over in bug 646136.
You need to log in before you can comment on or make changes to this bug.