Last Comment Bug 646377 - Focus event fired for accessible in previously active tab after opening a new tab from menu
: Focus event fired for accessible in previously active tab after opening a new...
Status: VERIFIED FIXED
: access, regression
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: mozilla10
Assigned To: alexander :surkov
:
Mentors:
Depends on: 673958
Blocks: focuseventa11y 659863
  Show dependency treegraph
 
Reported: 2011-03-30 01:34 PDT by James Teh [:Jamie]
Modified: 2011-09-29 07:55 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description James Teh [:Jamie] 2011-03-30 01:34:57 PDT
Str:
1. Open a document in one tab.
2. Press alt+f to access the File menu, then select New Tab.
Expected: A focus event should be fired on the Location bar.
Actual: A focus event is (correctly) fired on the Location Bar. However, a focus event is then incorrectly fired in the previously active tab (step 1), thus overriding the correct focus.

This occurs whenever a new tab is opened using a menu; e.g. History -> Recently Closed Tabs or Tools -> Add-ons Manager. It does not occur when opening new tabs using keyboard shortcuts (and I assume clicking buttons); e.g. control+t.

This bug means that focus appears to be in the previous document when screen reader users open a new tab from a menu. Screen reader users have to move the focus in some way to restore focus to the correct tab, which is annoying at best and extremely confusing at worst.

This does not occur in Firefox 3.6.
Comment 1 alexander :surkov 2011-09-16 10:18:59 PDT
Jamie, I can't see it on trunk. Can you?
Comment 2 James Teh [:Jamie] 2011-09-17 16:14:10 PDT
I can still reproduce this 100% using trunk (Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110917 Firefox/9.0a1).
Comment 3 alexander :surkov 2011-09-18 10:39:38 PDT
still can't reproduce, anyway, let's try it again after bug 673958 is fixed
Comment 4 James Teh [:Jamie] 2011-09-26 19:20:54 PDT
I verified that this is fixed in the last try build for bug 673958.
Comment 5 alexander :surkov 2011-09-28 02:27:24 PDT
fixed by bug 673958
Comment 6 Marco Zehe (:MarcoZ) on PTO until August 15 2011-09-29 07:55:53 PDT
Verified fixed in Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20110929 Firefox/10.0a1

Note You need to log in before you can comment on or make changes to this bug.