Looks like a typo:
rect.top = ev->area.x;
rect.left = ev->area.y;
rect.right = ev->area.x + ev->area.width;
rect.bottom = ev->area.y + ev->area.height;
Shouldn't it be rect.top = ev->area.y and rect.left = ev->area.x?
Jeff, can you take a look?
Yeah seems so.
Hmm. The code from comment 0 seems to be gone. Am I missing something?
Yeah, it's gone. It was a part of composite plug-ins. (Bug 624165).