Last Comment Bug 646414 - Width/Height mismatch in nsPluginNativeWindowGtk2.cpp
: Width/Height mismatch in nsPluginNativeWindowGtk2.cpp
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Jeff Muizelaar [:jrmuizel]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-30 04:36 PDT by Martin Stránský
Modified: 2011-08-02 13:52 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Martin Stránský 2011-03-30 04:36:52 PDT
http://mxr.mozilla.org/mozilla-central/source/modules/plugin/base/src/nsPluginNativeWindowGtk2.cpp#170

Looks like a typo:

  rect.top = ev->area.x;
  rect.left = ev->area.y;
  rect.right = ev->area.x + ev->area.width;
  rect.bottom = ev->area.y + ev->area.height;

Shouldn't it be rect.top = ev->area.y and rect.left = ev->area.x?
Comment 1 Boris Zbarsky [:bz] 2011-03-30 18:48:15 PDT
Jeff, can you take a look?
Comment 2 Jeff Muizelaar [:jrmuizel] 2011-03-30 19:35:41 PDT
Yeah seems so.
Comment 3 Boris Zbarsky [:bz] 2011-08-02 13:42:17 PDT
Hmm.  The code from comment 0 seems to be gone.  Am I missing something?
Comment 4 Martin Stránský 2011-08-02 13:52:06 PDT
Yeah, it's gone. It was a part of composite plug-ins. (Bug 624165).

Note You need to log in before you can comment on or make changes to this bug.