Last Comment Bug 646473 - "End User Rights" reads like a protest sign (should be End-User Rights)
: "End User Rights" reads like a protest sign (should be End-User Rights)
Status: RESOLVED FIXED
[bugday-20110401][good first bug][men...
: polish, ux-jargon, ux-tone
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- trivial (vote)
: Firefox 12
Assigned To: Jared Wein [:jaws] (please needinfo? me)
:
:
Mentors:
http://en.wikipedia.org/wiki/Compound...
Depends on:
Blocks: 579547 713012 713013 713016
  Show dependency treegraph
 
Reported: 2011-03-30 07:43 PDT by Jon Baumgartner
Modified: 2011-12-29 09:40 PST (History)
13 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch for bug 646473 (2.97 KB, patch)
2011-12-21 18:10 PST, Jared Wein [:jaws] (please needinfo? me)
no flags Details | Diff | Splinter Review
Patch for bug 646473 v2 (1.58 KB, patch)
2011-12-22 10:24 PST, Jared Wein [:jaws] (please needinfo? me)
ttaubert: review+
Details | Diff | Splinter Review

Description Jon Baumgartner 2011-03-30 07:43:26 PDT
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.2a1pre) Gecko/20110328 Firefox/4.2a1pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.2a1pre) Gecko/20110328 Firefox/4.2a1pre

I realize that "End User Rights" is supposed to indicate the rights for the end user, but not everyone knows what an "end user" is, and it sounds like Firefox is a proponent of ending rights for users.

Kind of an "Eats, Shoots, Leaves" scenario. 

How about changing the link text to "About Your Rights"? That's what displays when you click on it, anyway.

Reproducible: Always
Comment 1 Kai Liu 2011-04-03 16:13:55 PDT
I have to admit, that's a nice bug title; certainly caught my attention.  :)

http://en.wikipedia.org/wiki/Compound_modifier#Hyphenation_of_elements
http://www.oxforddictionaries.com/page/punctuationhyphen/hyphen-

Here, "end user" is a compound adjective: two words that act as a single adjective describing "rights".  And the rules of style state that when these things come before a noun, as is the case here, hyphenation is needed to eliminate the ambiguity that comment 0 speaks of.

I personally prefer just fixing the grammar and adding a hyphen, but I guess the suggestion in comment 0 is possible, too...
Comment 2 Alex Faaborg [:faaborg] (Firefox UX) 2011-04-12 10:16:42 PDT
>it sounds like Firefox is a proponent of ending rights for users.

yeah, two problems here, "end" can get parsed as discontinue, and "end user" is itself basically ux-jargon.

What we were going for, although in no way actually achieved, was to make the statement unambiguously positive.  We were finding that otherwise neutral statements like "about your rights" would skew negative (the user's assumption being that their rights were being restricted or in some way infringed).  There's considerably more discussion about this effect over in bug 571584.

How about we go with the slightly longer phrase:

"Protecting user rights"

This way if it ends up on a protest sign, at least it goes in the direction we were hoping for :)
Comment 3 Kai Liu 2011-04-12 15:00:19 PDT
(In reply to comment #2)
> "Protecting user rights"

That sounds a bit cheesy.  And it doesn't really fit the content of about:rights.  This is really a grammatical issue; the hyphen rule exists specifically to disambiguate in situations like this.  So, for now, let's just fix the grammar and add the hyphen (i.e., "End User" -> "End-User"), and we can ponder/discuss better wording choices later.
Comment 4 Jon Baumgartner 2011-04-13 05:44:47 PDT
The hyphen helps. I agree with Comment #2 that "End user" is not something that your average Firefox user (the end user! ha!) understands. 

What about the inconsistency between the link title and the title of the window that appears when you click it? If you're worried about that phrase ("About Your Rights") being parsed in a negative manner, I don't think you want it as the title when the user is browsing that information.
Comment 5 Kai Liu 2011-04-13 07:13:21 PDT
"End-User Rights" is typical text that you see just about everywhere.  So people should be familiar with it.

That having been said, yes, it probably is a tad too formal.  If we do change "End-User", I think we should change it to "Your" (i.e., "Your Rights" without the "About") for the sake of consistency with the rest of the text in that area.  We don't have "About Licensing", "Read Licensing Information", or "About Privacy"; we simply state what that link is pointing to, without any prepositions or verbs.  Keep it simple, short, and to the point.

In any case, let's just pick a simple, inconsequential and uncontroversial change for now: either add a hyphen or s/End User/Your/ to address the immediate issue of grammar, and we can file a new bug to consider and discuss more substantial changes to the wording.  Let's not let this turn into one of those (quite common) situations where people discuss and debate little details for so long that everyone loses interest, the bug gets abandoned, and nothing gets changed at all.
Comment 6 Alex Faaborg [:faaborg] (Firefox UX) 2011-04-13 07:34:37 PDT
>Let's not let this turn into one of
>those (quite common) situations where people discuss and debate little details
>for so long that everyone loses interest, the bug gets abandoned, and nothing
>gets changed at all.

You mean like most of bugzilla :)  I'll work with Margaret to get this fixed, and discussions of copy will be done offline since every single instance of that happening in bugzilla has been a tremendous bike shed.
Comment 7 Justin Dolske [:Dolske] 2011-04-14 17:34:33 PDT
(In reply to comment #3)

> > "Protecting user rights"
> 
> That sounds a bit cheesy.

Better: "Fights for the User." ;-)
Comment 8 Bill 2011-12-21 05:57:35 PST
We have one bug and one task:
- Bug: "End User Rights" > fix by adding hyphen, do it quickly, it contrasts loudly with FF's public positioning as the defender of web rights (it's not minor in my view)
- Task: Review texts in About box to identify improvements
Comment 9 Justin Dolske [:Dolske] 2011-12-21 17:58:53 PST
Let's focus this bug not ending the users' rights. :)

Patches welcome, this should be an easy fix:

1) Edit text in browser/locales/en-US/chrome/browser/aboutDialog.dtd
2) Change the entity name there from "bottomLinks.rights" to something else (say, bottomLinks.enduser). This is needed to make our localization tools flag this as a change localizers should consider.
3) Ensure all occurrences of "bottomLinks.rights" are changed to the new name. There are 2 instances in that .dtd file, and 1 in browser/base/content/aboutDialog.xul
Comment 10 Jared Wein [:jaws] (please needinfo? me) 2011-12-21 18:10:56 PST
Created attachment 583698 [details] [diff] [review]
Patch for bug 646473
Comment 11 Dão Gottwald [:dao] 2011-12-22 02:01:18 PST
Changing the entity name for this English-specific grammar issue probably causes more noise than necessary. It seems highly unlikely that localizers translated this wrongly. If you're still worried, send a message to mozilla.dev.l10n? And file a bug in https://bugzilla.mozilla.org/enter_bug.cgi?product=Mozilla%20Localizations&component=en-GB%20/%20English%20%28United%20Kingdom%29 (en-GB) and https://bugzilla.mozilla.org/enter_bug.cgi?product=Mozilla%20Localizations&component=en-ZA%20/%20English%20%28South%20Africa%29 (en-ZA).
Comment 12 Dão Gottwald [:dao] 2011-12-22 03:53:59 PST
> Changing the entity name for this English-specific grammar issue probably
> causes more noise than necessary. It seems highly unlikely that localizers
> translated this wrongly. If you're still worried, send a message to
> mozilla.dev.l10n? And file a bug in
> https://bugzilla.mozilla.org/enter_bug.
> cgi?product=Mozilla%20Localizations&component=en-GB%20/
> %20English%20%28United%20Kingdom%29 (en-GB) and
> https://bugzilla.mozilla.org/enter_bug.
> cgi?product=Mozilla%20Localizations&component=en-ZA%20/
> %20English%20%28South%20Africa%29 (en-ZA).

Pike, does this make sense?
Comment 13 Axel Hecht [:Pike] 2011-12-22 04:06:43 PST
Yeah. Looking at http://mxr.mozilla.org/l10n-mozilla-aurora/search?string=End+User+Rights&find=&findi=&filter=^[^\0]*%24&hitlimit=&tree=l10n-mozilla-aurora, filing a bug on km would be good, too.
Comment 14 Jared Wein [:jaws] (please needinfo? me) 2011-12-22 10:24:37 PST
Created attachment 583850 [details] [diff] [review]
Patch for bug 646473 v2

Removed the entity name change from the previous patch and I've filed bugs for the locales that also had "End User Rights".
Comment 15 Tim Taubert [:ttaubert] 2011-12-22 10:39:42 PST
Comment on attachment 583850 [details] [diff] [review]
Patch for bug 646473 v2

Review of attachment 583850 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good :)
Comment 16 Jared Wein [:jaws] (please needinfo? me) 2011-12-22 12:22:10 PST
https://hg.mozilla.org/integration/fx-team/rev/a9957e1d35bf
Comment 17 Tim Taubert [:ttaubert] 2011-12-29 09:40:35 PST
https://hg.mozilla.org/mozilla-central/rev/a9957e1d35bf

Note You need to log in before you can comment on or make changes to this bug.