Implement Bug 603790 in TB (remove the drop shadow and reduce border radius for buttons)

RESOLVED FIXED in Thunderbird 7.0

Status

RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: Paenglab, Assigned: Paenglab)

Tracking

(Blocks: 1 bug)

Trunk
Thunderbird 7.0
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
Bug 603790 removed the shadow and reduced the radii of the toolbarbuttons and textfields.

Attachment 523015 [details] shows the difference.

Should we follow this to stay in synch with FF?
(Assignee)

Comment 1

8 years ago
Andreas, I added you to know if we should follow this way.
Yes, I think we should!
It gives less of a heavy appearance, but still looks slick.
(Assignee)

Comment 3

7 years ago
Created attachment 535846 [details] [diff] [review]
Patch to follow Firefox

Patch implementing the border-radius-, box-shadow- and search-box changes from Firefox. This patch needs Bug 658872 applied.

I made also a whitespace cleanup to be TB style compliant.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #535846 - Flags: ui-review?(nisses.mail)
Attachment #535846 - Flags: review?(bwinton)
Comment on attachment 535846 [details] [diff] [review]
Patch to follow Firefox

Review of attachment 535846 [details] [diff] [review]:
-----------------------------------------------------------------

The code seems fine as far as I can tell.  r=me!
Attachment #535846 - Flags: review?(bwinton) → review+

Updated

7 years ago
Duplicate of this bug: 667237

Updated

7 years ago
Summary: Implement Bug 603790 in TB → Implement Bug 603790 in TB (remove the drop shadow and reduce border radius for buttons)

Updated

7 years ago
Blocks: 645294
Comment on attachment 535846 [details] [diff] [review]
Patch to follow Firefox

Looks great, ui-r+ from me!
Attachment #535846 - Flags: ui-review?(nisses.mail) → ui-review+
Keywords: checkin-needed
Checked in: http://hg.mozilla.org/comm-central/rev/1f367f357349
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 7.0

Comment 8

7 years ago
Comment on attachment 535846 [details] [diff] [review]
Patch to follow Firefox

It looks like this is only in 8.0, not 7.0, since I don't see it in a current comm-central checkout. Since bug 667248 depends on this patch, we should probably include this in comm-aurora and comm-beta as well.
Attachment #535846 - Flags: approval-comm-beta?
Attachment #535846 - Flags: approval-comm-aurora?
Comment on attachment 535846 [details] [diff] [review]
Patch to follow Firefox

This also depends on at least one more patch, so I don't think we want to take it this late in the cycle.
Attachment #535846 - Flags: approval-comm-beta?
Attachment #535846 - Flags: approval-comm-beta-
Attachment #535846 - Flags: approval-comm-aurora?
Attachment #535846 - Flags: approval-comm-aurora-
You need to log in before you can comment on or make changes to this bug.