Write copy for the Future-Release Newsletter & Download page

RESOLVED FIXED

Status

Marketing
Copy
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: lmesa, Assigned: Tara (musingt))

Tracking

Details

Attachments

(4 attachments)

446.08 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document
Details
146.27 KB, image/png
Details
4.48 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document
Details
13.66 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document
Details
(Reporter)

Description

7 years ago
We will be creating a simple page where people can sign up for our aurora (yay!) and beta newsletters. 

I think we need a headline, sub-headline and a few lines describing what each channel is and what to expect by joining those channels. 

I will share the value propostition document for all of these channels to get you started.

We probably want 2-3 sentences max on each channel.
(Reporter)

Comment 1

7 years ago
(In reply to comment #0)

> 
> I will share the value propostition document for all of these channels to get
> you started.
> 
Just kidding--Matej, you already have this.

Comment 2

7 years ago
(In reply to comment #1)
> (In reply to comment #0)
> 
> > 
> > I will share the value propostition document for all of these channels to get
> > you started.
> > 
> Just kidding--Matej, you already have this.

I'm having trouble tracking it down. Can you please resend? Thanks!
(Reporter)

Comment 3

7 years ago
resent--its a gdoc/spreadsheet.
(Assignee)

Comment 4

7 years ago
Laura, if you can share that doc as an attachment that would be great.  It would help us know roughly how much copy there is (even if it's FPO) so that the designer can throw it into the page layout and start on the design, while copy is being finalized.
(Reporter)

Comment 5

7 years ago
(In reply to comment #4)
> Laura, if you can share that doc as an attachment that would be great.  It
> would help us know roughly how much copy there is (even if it's FPO) so that
> the designer can throw it into the page layout and start on the design, while
> copy is being finalized.

So, the doc I have doesn't have the copy we should be using, it's more explaining the value per channel.  I also don't feel sharing it in public either. 

Can I send the link to you to share with the designer?
(Reporter)

Comment 6

7 years ago
Created attachment 523418 [details]
What the page we had the newsletters looked like before
(Reporter)

Updated

7 years ago
Summary: Write copy for the Future-Release Email sign up page → Write copy for the Future-Release Newsletter & Download page
(Reporter)

Comment 7

7 years ago
Created attachment 523506 [details]
New download/newsletter page merge

Matej, as discussed, we will combine this newsletter and download page into one.  It sounded like you think you can get this done for monday, which would be awesome. 

basically need:
1.Name for the page -- "future releases"?
2. headline
3. sub headline
4. 2-3 sentence about aurora
5. 2-3 senetences about beta
6. 2-3 sentences about firefox 4
7. Newsletter sign-up copy (this is one sign up form for all three newsletters).

Comment 8

7 years ago
Created attachment 523898 [details]
Copy for Future Release page

Here's the copy for the newsletter and download page. I've created some options for headlines and subheads, otherwise should be pretty straightforward.

Comment 9

7 years ago
Thanks Matej, looks great.  I made edits to your copy to better fit the design in Bug 646868.  I think the bullet points still need a bit of work so let's talk about that tomorrow.  I'll post what I have now to the design bug since we can change the bullet points after the page is developed/

Comment 10

7 years ago
Created attachment 524072 [details]
Mayumi Edits to Copy for Future Release page
I've taken a stab at cutting down the bullet points and making some other tweaks. Over all, John and I were feeling that the copy was too long once we saw it in layout (my bad). I've removed the word "Channel" under each channel name, mostly because I think it's unnecessary, but also not sure it's adding anything. But if it's crucial, I'm happy to put them back in. Definitely think we don't need "Firefox" in the name of the Final Release channel. If we put it there, it should also be in the other two, and that would be really redundant.

Also, looks like we've got the Nightly logo on Aurora, and Aurora on Beta.


[HEADLINE]
Welcome to the Future of Firefox

[SUBHEAD]
Download and test the build that’s right for you and sign up for a channel newsletter to stay in the loop.

[SUBHEAD]
Aurora

[COPY]
• Experience the newest innovations in an unstable environment that's not for the faint of heart
• Provide feedback on features and performance to help determine what makes the final release

[CTA]
Download Mozilla Firefox Aurora

[SUBHEAD]
Beta

[COPY]
• Experience cutting edge features but with more stability
• Provide feedback to help refine and polish what will be in the final release

[CTA]
Coming Soon! Get notified when Beta is ready.

[SUBHEAD]
Final Release

[COPY]
• Enjoy the tried and tested final release being used by hundreds of millions world wide
• Stay in control of your online experience with super speed, easy customization and the latest Web technologies

[CTA]
Download Mozilla Firefox 4

Comment 12

7 years ago
Thanks Matej. +1 for everything in comment #11.

Two nits, though:
- should it be "Download and test the build that’s right for you, and sign up for a channel newsletter to stay in the loop."? (added a comma before "and sign up for)
- isn't it "worldwide" instead of "world wide"?

Also, talked with Mayumi and confirmed that we can drop "channel" under each channel name (next to the logos) and only use Final Release instead of Firefox Final Release.
(In reply to comment #12)
> Thanks Matej. +1 for everything in comment #11.
> 
> Two nits, though:
> - should it be "Download and test the build that’s right for you, and sign up
> for a channel newsletter to stay in the loop."? (added a comma before "and sign
> up for)

Don't need the comma, but agree that it makes the sentence clearer and easier to parse. Let's add it in.


> - isn't it "worldwide" instead of "world wide"?

Seeing it again, I think we should change it to "around the world:"

• Enjoy the tried and tested final release being used by hundreds of millions
around the world

Comment 14

7 years ago
Sounds good to me. 

Mayumi, what do you think? Let us know when you get a chance so we can post this over in the build bug.
(Reporter)

Comment 15

7 years ago
Also, Matej--I'm just going to combine the bullets into sentences for product, is that okay with you or should I take a different approach?

L
(In reply to comment #15)
> Also, Matej--I'm just going to combine the bullets into sentences for product,
> is that okay with you or should I take a different approach?

Eeep! Totally forgot that part. Here you go:

Experience the newest innovations in an unstable environment that's not for the faint of heart. Provide feedback on features and performance to help determine what makes the final release.

Experience cutting edge features with more stability. Provide feedback to help refine and polish what will be in the final release.

Enjoy the tried and tested final release being used by hundreds of millions around the world. Stay in control of your online experience with super speed, easy customization and the latest Web technologies.

Comment 17

7 years ago
+1, only thing to add for Aurora is "available in en-US only" somewhere in the copy.  That's all, thanks
Here's the complete deck again, with the last few changes from the last few comments. I added the en-US line below the download button for Aurora. If that doesn't make sense, let me know. Might come down to where it looks best design-wise.


[HEADLINE]
Welcome to the Future of Firefox

[SUBHEAD]
Download and test the build that’s right for you, and sign up for a channel
newsletter to stay in the loop.

[SUBHEAD]
Aurora

[COPY]
• Experience the newest innovations in an unstable environment that's not for
the faint of heart
• Provide feedback on features and performance to help determine what makes the
final release

[CTA]
Download Mozilla Firefox Aurora

[BELOW BUTTON]
Available in en-US only

[SUBHEAD]
Beta

[COPY]
• Experience cutting edge features but with more stability
• Provide feedback to help refine and polish what will be in the final release

[CTA]
Coming Soon! Get notified when Beta is ready.

[SUBHEAD]
Final Release

[COPY]
• Enjoy the tried and tested final release being used by hundreds of millions
around the world
• Stay in control of your online experience with super speed, easy customization and the latest Web technologies

[CTA]
Download Mozilla Firefox 4

[NEWS — HEADLINE]
Get the latest channel news

[NEWS — COPY]
Sign up for one or all of our Firefox channel newsletters.

[FIELDS & BUTTONS]
Your email address		
Aurora		
Beta	
Final Release: General Mozilla News
Location				
I agree to the privacy policy
Sign me up!
We will only send you Mozilla-related information

Comment 19

7 years ago
Awesome, thanks Matej. Am closing this bug - let's move any further discussion/revision over to bug 647241
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.