Closed Bug 647090 Opened 10 years ago Closed 10 years ago

general.useragent.vendor preference no longer updates the navigator.vendor property

Categories

(Core :: General, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: bugzilla, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

Changing the general.useragent.vendor preference no longer updates the navigator.vendor property. This used to work in Firefox 3.6.

Reproducible: Always

Steps to Reproduce:
1. Go to about:config
2. Create a new string entry for general.useragent.vendor and set it to 'Test'
3. Enter javascript:navigator.vendor in the URL bar
Actual Results:  
Nothing is displayed

Expected Results:  
'Test' should be displayed

Note that these exact steps work in Firefox 3.6. I know some user agent changes were made in Firefox 4, but I still think changing this preference should work, no?
No.  All of the general.useragent preferences except general.useragent.override have been disabled.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
In particular, see bug 591573 for the specific case of general.useragent.vendor.
Blocks: 591573
Duplicate of this bug: 1172960
You need to log in before you can comment on or make changes to this bug.