One-minute delay between commands when checking/sending mail

RESOLVED INVALID

Status

--
major
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: f_weed, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.94 KB, application/octet-stream
Details
(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.15) Gecko/20110303 Thunderbird/3.1.9

App stalls for several minutes when checking/sending mail, eventually completes. Wireshark show successful DNS query early in the capture session, then the following:

Time     Action
-------  ------------------------------------------------------------------
072.210  Connection request to port 110
072.375  Expected handshake, server responds "+OK POP3 ...more..."
133.209  Thunderbird sends "CAPA"
133.290  Server responds "-ERR Invalid command"
194.208  Thunderbird sends "USER ........"
194.291  Server responds "+OK ......."
255.208  Thunderbird sends "PASS ....."
255.310  Server responds "+OK ......"
316.208  Thunderbird sends "STAT"
316.289  Server responds "+OK ..."
377.208  Thunderbird sends "QUIT"
377.290  Server responds "+OK Bye!"

... promptly followed by close of socket. ACK messages not shown above, but all returned promptly when expected.

Reproducible: Sometimes

Steps to Reproduce:
1. Above produced when clicking "Get Mail."
2. Similar delay times seen when attempting to send mail.

Actual Results:  
Response similar to above occurs ~8 times out of 10

Other times response is complete in ~1 second or so

Expected Results:  
Expect complete response in ~1 second if no mail to receive.
(Reporter)

Comment 1

8 years ago
Created attachment 523697 [details]
Wireshark .pcap

Invalid checksum on some packets due to obfuscation of account details.

Comment 2

8 years ago
Fred when did this start?  Does it happen with your AV and firewall SW disabled ?
(Reporter)

Comment 3

8 years ago
Wayne, this started 2-3 days before making the bug report and persisted over reboots. This apparently is a McAfee bug: Normal Thunderbird behavior after disabling "Real time scanning." I'm guessing they introduced a bug in an update. Just a guess, they don't bother to log their updates, but would explain why the problem seemed to pop up out of nowhere. Sorry for the report, a bloated AV/firewall product should be the first suspect when any network-related problem occurs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE

Updated

8 years ago
Resolution: INCOMPLETE → INVALID
You need to log in before you can comment on or make changes to this bug.