Navigating away from App Tab changes URL

RESOLVED DUPLICATE of bug 598587

Status

()

RESOLVED DUPLICATE of bug 598587
8 years ago
8 years ago

People

(Reporter: iNoob.x, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

When your current page is an App Tab and you enter an URL into the address bar or type in a phrase to search, the URL of the App Tab becomes the new URL. Please see "Steps to Reproduce".

Reproducible: Always

Steps to Reproduce:
1.Pin an App Tab with any website (e.g. Facebook.com). 
2.Open the new App Tab
3.In the address bar enter any URL that's different from the App Tab's URL (e.g. gizmodo.com)
4.The App Tab's URL gets changed to the new URL (e.g. Gizmodo)
Actual Results:  
The URL of the App Tab becomes the new URL (e.g. Gizmodo.com)

Expected Results:  
I expected the App Tab to remain at the original URL (e.g. Facebook.com).

Not sure if this is a bug or a feature, but it's annoying. Maybe make it so that a new tab opens when you type something into the address bar when the current page is an App Tab.

Updated

8 years ago
Duplicate of this bug: 647448

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 598587
You need to log in before you can comment on or make changes to this bug.