searching for a link using the ' shortcut finds links that are not visible on the page.

RESOLVED WORKSFORME

Status

()

enhancement
RESOLVED WORKSFORME
8 years ago
3 years ago

People

(Reporter: postingandjunk, Unassigned)

Tracking

2.0 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0

for example it finds links that are hidden in java script menus.
searching for "ranking" will display the behavior

Reproducible: Always

Steps to Reproduce:
1. press '
2. type in ranking
Actual Results:  
see links are found but nothing is highlighted, the problem being that the link isn't visible on the page but will show up if you expand the menus

Expected Results:  
only the visible links should be searchable

Comment 1

8 years ago
I can reproduce on Mozilla/5.0 (Windows NT 6.0; rv:2.2a1pre) Gecko/20110404 Firefox/4.2a1pre ID:20110404030429 but I personally would consider this bug a feature.

I'll be using extensively for the time being and hope they don't fix it, is a big usability improvement ad you don't have to mouse on the menus but you still see where you're going on the "URL bubble" =)
(Reporter)

Comment 2

8 years ago
with more research it seems all the browsers behave the same way. i think it would be really useful if there was some way of knowing that the link is not visible or something along those lines. so i guess this isn't a bug but a feature request.

Updated

8 years ago
Severity: normal → enhancement
Component: Keyboard Navigation → Find Toolbar
Product: Firefox → Toolkit
QA Contact: keyboard.navigation → fast.find
Version: unspecified → 2.0 Branch
I think this issue has since been resolved.
If you feel this issue was closed in error, please feel free to re-open.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.