Closed Bug 647716 Opened 11 years ago Closed 10 years ago

After closing Firefox, upon reopen, a windows says there is already an instance of Firefox running. Please wait for it to close before starting a new instance.

Categories

(Firefox :: General, defect)

5 Branch
x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 407981

People

(Reporter: don_ensley, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

After closing Firefox, then upon reopening it, a windows pops up and says that I have to wait because there  is already an instance of Firefox running. I have to wait too long after closing Firefox for the process to stop!

Reproducible: Always

Steps to Reproduce:
1. Open Firefox. 
2. Close Firefox.
3. Immediately reopen Firefox. Observe box saying Firefox is already running.
Actual Results:  
You will have to wait at least 15 seconds until you can start a new instance of Firefox and have it open correctly. It should instantly stop.
Any update?
Error occurs in both safe mode and not in safe mode for Firefox 4, windows 7, 64-bit.
Keywords: 64bit
For example, IE 9 after shutting down will immediately restart OK, starting a new browser window. Firefox says there is another instance (i.e. as if it does not shut down immediately when the browser window is closed). The instance of Firefox that lingers prevents a new window from immediately being opened.
Version: unspecified → 4.0 Branch
This bug lists the common reasons of why it occurs. https://bugzilla.mozilla.org/show_bug.cgi?id=639307

I can replicate this bug on Mac OS X 10.6.7 64-bit running Firefox 5. I have also replicated on a Fedora box but I don't have access to that right now to post the information.
Keywords: 64bit
Version: 4.0 Branch → 5 Branch
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 407981
You need to log in before you can comment on or make changes to this bug.