Closed Bug 647739 Opened 10 years ago Closed 10 years ago

Embed video replays after closing Facebook photo page

Categories

(Core :: Plug-ins, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 90268

People

(Reporter: mmm, Unassigned)

References

()

Details

Attachments

(2 files)

This issue shows up on Facebook news feeds or profiles.

STR:
Play an embed video on a Facebook page and pause it, in my tests I played a Youtube video.
From the same page click on a photo that takes you to the lightbox-like interface. Hit Esc to exit from the photo.

At this point the embed video replays from the start when it was paused before.
What does the page actually do in this case?  Does it send the plugin through display:none somewhere in there?
(In reply to comment #1)
> What does the page actually do in this case?  Does it send the plugin through
> display:none somewhere in there?

Bingo! The attached testcase toggles display:none and does a getBoundingClientRect to force a repaint, and it causes the problem to show up.
I don't think display:none; is what's going on here. I don't see that happening on Facebook.

As well, Google Chrome has the same behaviour as Firefox on Mehdi's attachment, whereas it doesn't have the bug on Facebook.  Investigating for a new reduced testcase.
Right.  display:none would _definitely_ have this behavior; the question is what the page actually does.
Attached file Reduced testcase
Reduced testcase.

changing the overflow attribute on body to hidden and back seems to cause the plugin to reload.
Ah, ok.  So yeah, reframing.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 90268
Duplicate of this bug: 643683
You need to log in before you can comment on or make changes to this bug.